summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <jimw@mysql.com>2005-11-02 18:29:06 -0800
committerunknown <jimw@mysql.com>2005-11-02 18:29:06 -0800
commit8355bce65862d3effea30f20f12186c8000b0247 (patch)
treeb1867ae6fe89f4a26b8a423974441054508099ef /configure.in
parentc3ac502ab16db7118c4b1f2a70a300e6bd40af85 (diff)
downloadmariadb-git-8355bce65862d3effea30f20f12186c8000b0247.tar.gz
Don't add optimization flags to CFLAGS if the user specified their
own CFLAGS (ditto for CXXFLAGS). (Bug #12640) configure.in: Only add optimization flags when no CFLAGS (and/or CXXFLAGS) were specified.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 40a3e8ea5d4..f10c7b7a96e 100644
--- a/configure.in
+++ b/configure.in
@@ -1672,6 +1672,19 @@ if expr "$SYSTEM_TYPE" : ".*netware.*" > /dev/null; then
OPTIMIZE_CXXFLAGS="$OPTIMIZE_CXXFLAGS -DNDEBUG"
fi
+# If the user specified CFLAGS, we won't add any optimizations
+if test -n "$SAVE_CFLAGS"
+then
+ OPTIMIZE_CFLAGS=""
+ DEBUG_OPTIMIZE_CC=""
+fi
+# Ditto for CXXFLAGS
+if test -n "$SAVE_CXXFLAGS"
+then
+ OPTIMIZE_CXXFLAGS=""
+ DEBUG_OPTIMIZE_CXX=""
+fi
+
AC_ARG_WITH(debug,
[ --without-debug Build a production version without debugging code],
[with_debug=$withval],