summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-10-24 20:32:07 +0200
committerunknown <msvensson@neptunus.(none)>2006-10-24 20:32:07 +0200
commit9c9bf0aff21df3ec9395d124f72fc1eeb17c2c16 (patch)
treee6c62a7269e3423ff0d457cb05e1342ff86a1c8c /configure.in
parent61e3438fe26e1e3a67441a6408b6488d4a8940c5 (diff)
downloadmariadb-git-9c9bf0aff21df3ec9395d124f72fc1eeb17c2c16.tar.gz
WL#3462 Add testing of MySQL client ABI to prevent unintentional ABI breaks
BUG#23427 incompatible ABI change in 5.0.26? - Use the icheck tool if avaliable and compare the current mysql.h to a version controlled reference file BitKeeper/etc/ignore: Added include/check_abi include/mysql_h.ic to the ignore list configure.in: Look for icheck in configure include/Makefile.am: Add rule to build mysql_h.ic if icheck is avaliable Add rule to compare mysql_h.ic to the version controlled reference file mysql_h_abi.ic include/mysql.h: Add comment about taking care when editing mysql.h Add example how to add reserved fiels in the structs to allow for features to be added without breaking ABI include/mysql_h_abi.ic: Add new file describing the libmysqlclient ABI used as a reference to detect ABI breakage
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6cccb1bb90e..20dea3595de 100644
--- a/configure.in
+++ b/configure.in
@@ -508,6 +508,10 @@ AC_SUBST(DOXYGEN)
AC_SUBST(PDFLATEX)
AC_SUBST(MAKEINDEX)
+# icheck, used for ABI check
+AC_PATH_PROG(ICHECK, icheck, no)
+AC_SUBST(ICHECK)
+
# Lock for PS
AC_PATH_PROG(PS, ps, ps)
AC_MSG_CHECKING("how to check if pid exists")