summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjimw@mysql.com <>2005-08-23 11:25:24 -0700
committerjimw@mysql.com <>2005-08-23 11:25:24 -0700
commitcf5dd176c0d83938a5fdc13cc7a4a5d049158a2e (patch)
tree8f25e99f65e13c5974f8f6c711c8e7e6a78520a7 /configure.in
parent8888e9172d724850195a7eb6597b658a54f98042 (diff)
downloadmariadb-git-cf5dd176c0d83938a5fdc13cc7a4a5d049158a2e.tar.gz
Fix build using --without-server. (Bug #11680)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 8a5220dbf38..612a51586ab 100644
--- a/configure.in
+++ b/configure.in
@@ -2444,7 +2444,7 @@ thread_dirs=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
-sql_client_dirs="libmysql strings regex client"
+sql_client_dirs="strings regex mysys sql/share libmysql client"
linked_client_targets="linked_libmysql_sources"
if test "$THREAD_SAFE_CLIENT" != "no"
@@ -2482,10 +2482,10 @@ then
AC_DEFINE([THREAD], [1],
[Define if you want to have threaded code. This may be undef on client code])
# Avoid _PROGRAMS names
- THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o"
+ THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o mf_keycache.o"
AC_SUBST(THREAD_LOBJECTS)
server_scripts="mysqld_safe mysql_install_db"
- sql_server_dirs="strings mysys dbug extra regex"
+ sql_server_dirs="strings dbug extra regex"
#
@@ -2593,7 +2593,6 @@ esac
# END of configuration for optional table handlers
#
sql_server_dirs="$sql_server_dirs myisam myisammrg heap vio sql"
-
fi
# IMPORTANT - do not modify LIBS past this line - this hack is the only way