summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkent@mysql.com <>2005-06-28 04:44:27 +0200
committerkent@mysql.com <>2005-06-28 04:44:27 +0200
commit7817b69d808dfa4b8ec7ac1915de33584177b9c2 (patch)
tree264dd2455304a98f2ec3006b8f88e902a1c340d0 /configure.in
parentfab90ce856993ccd7b1c07d667b09e18c290cca7 (diff)
downloadmariadb-git-7817b69d808dfa4b8ec7ac1915de33584177b9c2.tar.gz
configure.in:
Enable build with CXX=gcc and gcc version 4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d454d23b38c..0889e9a3257 100644
--- a/configure.in
+++ b/configure.in
@@ -419,9 +419,14 @@ then
if echo $CXX | grep gcc > /dev/null 2>&1
then
- if $CXX -v 2>&1 | grep 'version 3' > /dev/null 2>&1
+ AC_MSG_CHECKING([if CXX is gcc 3 or 4])
+ if $CXX -v 2>&1 | grep 'version [[34]]' > /dev/null 2>&1
then
+ AC_MSG_RESULT([yes])
+ AC_MSG_NOTICE([using MySQL tricks to avoid linking C++ code with C++ libraries])
CXXFLAGS="$CXXFLAGS -DUSE_MYSYS_NEW -DDEFINE_CXA_PURE_VIRTUAL"
+ else
+ AC_MSG_RESULT([no])
fi
fi
fi