summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@donna.mysql.fi <>2001-04-13 22:09:33 +0300
committermonty@donna.mysql.fi <>2001-04-13 22:09:33 +0300
commitbc7731c0c767611f21225d3855ee4b447beebeb7 (patch)
tree334db2402b4aee273ded1ee0710570238dbc373a /configure.in
parentfc6dcf4df7c5c75ffcc5dd1a5c9c5dcb10442b0c (diff)
downloadmariadb-git-bc7731c0c767611f21225d3855ee4b447beebeb7.tar.gz
Changed -O6 to -O3
Portability fix for Innodb
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f230f454690..807de749b73 100644
--- a/configure.in
+++ b/configure.in
@@ -691,7 +691,7 @@ int main()
# Some system specific hacks
#
-MAX_C_OPTIMIZE="-O6"
+MAX_C_OPTIMIZE="-O3"
case $SYSTEM_TYPE in
*solaris2.7*)
@@ -1333,7 +1333,7 @@ AC_CHECK_FUNCS(alarm bmove \
sigset sigthreadmask pthread_sigmask pthread_setprio pthread_setprio_np \
pthread_setschedparam pthread_attr_setprio pthread_attr_setschedparam \
pthread_attr_create pthread_getsequence_np pthread_attr_setstacksize \
- pthread_condattr_create rwlock_init pthread_rwlock_rdlock \
+ pthread_condattr_create rwlock_init pthread_rwlock_rdlock pthread_yield\
dlopen dlerror fchmod getpass getpassphrase initgroups mlockall)
# Sanity check: We chould not have any fseeko symbol unless