summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormmj@tiger.mmj.dk <>2007-01-11 09:19:32 +0100
committermmj@tiger.mmj.dk <>2007-01-11 09:19:32 +0100
commit49913f2a95d8dcb3ff05160f4c5bf22222bb5f26 (patch)
tree255d4cdb83d5c64b996d7d22b14af8b5f4ee8b06 /configure.in
parent27d56afcfc5c7ccb7793d15f5643fcc058ceaa51 (diff)
parentba7b6e86f269ed5a634af13f422b92be3294431c (diff)
downloadmariadb-git-49913f2a95d8dcb3ff05160f4c5bf22222bb5f26.tar.gz
Merge mjorgensen@bk-internal.mysql.com:/home/bk/mysql-5.0-sage
into tiger.mmj.dk:/Users/mmj/bktrees/mysql-5.0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 99a9f3b74ea..493fe8f174f 100644
--- a/configure.in
+++ b/configure.in
@@ -713,6 +713,22 @@ else
AC_MSG_RESULT([no])
fi
+# If we should allow init-file, skip-grant-table and bootstrap options
+AC_MSG_CHECKING(If we should should enable init-file, skip-grant-table options and bootstrap)
+AC_ARG_ENABLE(grant-options,
+ [ --disable-grant-options Disables the use of --init-file, --skip-grant-tables and --bootstrap options],
+ [ mysql_grant_options_enabled=$enableval ],
+ [ mysql_grant_options_enabled=yes ]
+ )
+if test "$mysql_grant_options_enabled" = "yes"
+then
+ AC_MSG_RESULT([yes])
+else
+ AC_DEFINE([DISABLE_GRANT_OPTIONS], [1],
+ [Disables the use of --init-file, --skip-grant-tables and --bootstrap options])
+ AC_MSG_RESULT([no])
+fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked