summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@work.mysql.com>2001-03-08 18:02:48 +0100
committerunknown <tim@work.mysql.com>2001-03-08 18:02:48 +0100
commit8303fd97d5ed1882fe0d9088ffd0e640c7e46fda (patch)
treecfb33119c6e8dd8e1164d1b1580cfd0b32bca7e5 /configure.in
parent0629edd18f68764e486ada3272d64bcb24bc5628 (diff)
downloadmariadb-git-8303fd97d5ed1882fe0d9088ffd0e640c7e46fda.tar.gz
Make configure generate a fake bdb/build_unix/db.h file, so that
'make distcheck' will work. I hope. This is an ugly hack.... configure.in: Force a fake bdb/build_unix/db.h file in case we're doing a VPATH build and using dependency files from an older build. This happens when 'make distcheck' is run.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1939f6191d1..e4987802ebb 100644
--- a/configure.in
+++ b/configure.in
@@ -1906,6 +1906,28 @@ dnl echo "bdb = '$bdb'; inc = '$bdb_includes', lib = '$bdb_libs'"
fi
AC_DEFINE(HAVE_BERKELEY_DB)
+ else
+ if test -d bdb; then :
+ else
+ mkdir bdb && mkdir bdb/build_unix && cat <<EOF > bdb/build_unix/db.h
+
+This file is a placeholder to fool make. The way that automake
+handles 'make distcheck' (calling the VPATH configure with different
+options from the original configure) causes make to think that mysqld
+depends on this file, even though Berkeley DB isn't being used.
+
+Obviously, if this file *is* used, it'll break and hopefully we can find
+out why this file was generated by $(top_srcdir)/configure instead of
+the real db.h.
+
+If you run into some problems because of this file, please use mysql_bug
+to generate a bug report, and give the exact output of make and any
+details you can think of. Send the message to bugs@lists.mysql.com.
+
+Thank you!
+
+EOF
+ fi
fi
if test X"$have_innobase_db" = Xyes