summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@cane.mysql.fi>2000-12-26 10:56:20 +0200
committerunknown <tim@cane.mysql.fi>2000-12-26 10:56:20 +0200
commit9b3ebee23cf66bbff5843cd051c5eaa492446bdf (patch)
tree4adb473bf80022537874586b94c5be7a85bec48c /configure.in
parent910e932dd0cf1e7bf86e7f2deb7afb514e791b84 (diff)
parent70c7b3c02d0a8f54b16c24c35d03f576521472fa (diff)
downloadmariadb-git-9b3ebee23cf66bbff5843cd051c5eaa492446bdf.tar.gz
Merge
configure.in: SCCS merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index db2c93891eb..9731b4f3f5f 100644
--- a/configure.in
+++ b/configure.in
@@ -436,10 +436,16 @@ AM_CONDITIONAL(ASSEMBLER, test ASSEMBLER_x86 = "" -o ASSEMBLER_x86 = "")
AC_MSG_CHECKING(whether to use RAID)
AC_ARG_WITH(raid,
[ --with-raid Enable RAID Support],
- [ AC_DEFINE(USE_RAID)
- AC_MSG_RESULT(yes) ],
- [ AC_MSG_RESULT(no) ]
+ [ USE_RAID=$withval ],
+ [ USE_RAID=no ]
)
+if test "$USE_RAID" = "yes"
+then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([USE_RAID])
+else
+ AC_MSG_RESULT([no])
+fi
# Use this to set the place used for unix socket used to local communication.
AC_ARG_WITH(unix-socket-path,