summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-05-27 23:21:03 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-05-27 23:21:03 +0200
commit0d3df46fe768c39f59a809c32bd5d9814f0a9594 (patch)
tree849a343396d273d78747ab2f68b71b88d1b26a34 /configure.in
parente3a3110fc60919dceee7e39da26af8b481c558a9 (diff)
downloadmariadb-git-0d3df46fe768c39f59a809c32bd5d9814f0a9594.tar.gz
sql_parse.cc, config-win.h, config-netware.h:
Don't try determine stack direction at configure time compiler_flag.m4: Use AC_TRY_COMPILE and AC_TRY_LINK instead of AC_TRY_RUN where possible misc.m4, configure.in: Use fourth argument to AC_TRY_RUN, to be used in cross compilation Don't try determine stack direction at configure time configure.in: Use fourth argument to AC_TRY_RUN, to be used in cross compilation Don't try determine stack direction at configure time config/ac-macros/compiler_flag.m4: Use AC_TRY_COMPILE and AC_TRY_LINK instead of AC_TRY_RUN where possible config/ac-macros/misc.m4: Use fourth argument to AC_TRY_RUN, to be used in cross compilation Don't try determine stack direction at configure time include/config-netware.h: Don't try determine stack direction at configure time include/config-win.h: Don't try determine stack direction at configure time sql/sql_parse.cc: Don't try determine stack direction at configure time
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index e3c6edb9b0f..7c18aeb4fc6 100644
--- a/configure.in
+++ b/configure.in
@@ -264,7 +264,10 @@ AC_TRY_RUN([
AC_MSG_RESULT("ptr")],
[AC_DEFINE(SPRINTF_RETURNS_GARBAGE, [1], [Broken sprintf])
AC_MSG_RESULT("garbage")])
- ])
+ ],
+ # Cross compile, assume POSIX
+ [AC_DEFINE(SPRINTF_RETURNS_INT, [1], [POSIX sprintf])
+ AC_MSG_RESULT("int (we assume)")])
;;
esac
@@ -1784,8 +1787,6 @@ MYSQL_TYPE_ACCEPT
#---END:
# Figure out what type of struct rlimit to use with setrlimit
MYSQL_TYPE_STRUCT_RLIMIT
-# Find where the stack goes
-MYSQL_STACK_DIRECTION
# We want to skip alloca on irix unconditionally. It may work on some version..
MYSQL_FUNC_ALLOCA
# Do struct timespec have members tv_sec or ts_sec