summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <mjorgensen@production.mysql.com>2007-01-12 00:10:18 +0100
committerunknown <mjorgensen@production.mysql.com>2007-01-12 00:10:18 +0100
commit46169fdc9b43e35dedf5f8ac43f6c6fb080bf336 (patch)
treec4c8dcc1816d243dc4436275e97dd18e56874c31 /configure.in
parent50361d9a44ddce3d0253feba9c658a17b2b0a517 (diff)
parent8326c2c25dd9038781951b00ed6e6e04e612e8ff (diff)
downloadmariadb-git-46169fdc9b43e35dedf5f8ac43f6c6fb080bf336.tar.gz
Merge bk-internal:/home/bk/mysql-5.0
into production.mysql.com:/usersnfs/mjorgensen/bktrees/mysql-5.0-community configure.in: Auto merged sql/item_func.cc: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 6 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 493fe8f174f..b86353d6b79 100644
--- a/configure.in
+++ b/configure.in
@@ -7,7 +7,7 @@ AC_INIT(sql/mysqld.cc)
AC_CANONICAL_SYSTEM
# The Docs Makefile.am parses this line!
# remember to also change ndb version below and update version.c in ndb
-AM_INIT_AUTOMAKE(mysql, 5.0.34)
+AM_INIT_AUTOMAKE(mysql, 5.0.35)
AM_CONFIG_HEADER(config.h)
PROTOCOL_VERSION=10
@@ -19,7 +19,7 @@ SHARED_LIB_VERSION=$SHARED_LIB_MAJOR_VERSION:0:0
# ndb version
NDB_VERSION_MAJOR=5
NDB_VERSION_MINOR=0
-NDB_VERSION_BUILD=34
+NDB_VERSION_BUILD=35
NDB_VERSION_STATUS=""
# Set all version vars based on $VERSION. How do we do this more elegant ?
@@ -1089,7 +1089,6 @@ case $SYSTEM_TYPE in
fi
;;
*darwin*)
- AC_DEFINE([DEFAULT_SKIP_THREAD_PRIORITY], [1], [default to skip thread priority])
if test "$ac_cv_prog_gcc" = "yes"
then
FLAGS="-D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT"
@@ -2511,14 +2510,12 @@ thread_dirs=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
-sql_client_dirs=
+sql_client_dirs="strings regex mysys libmysql client"
linked_client_targets="linked_libmysql_sources"
-if test "$THREAD_SAFE_CLIENT" = "no"
+if test "$THREAD_SAFE_CLIENT" != "no"
then
- sql_client_dirs="strings regex mysys extra libmysql client"
-else
- sql_client_dirs="strings regex mysys extra libmysql libmysql_r client"
+ sql_client_dirs="libmysql_r $sql_client_dirs"
linked_client_targets="$linked_client_targets linked_libmysql_r_sources"
AC_CONFIG_FILES(libmysql_r/Makefile)
AC_DEFINE([THREAD_SAFE_CLIENT], [1], [Should be client be thread safe])
@@ -2547,17 +2544,13 @@ AM_CONDITIONAL(HAVE_NETWARE, test "$netware_dir" = "netware")
export CC CXX CFLAGS CXXFLAGS LD LDFLAGS AR
ac_configure_args="$ac_configure_args CFLAGS='$CFLAGS' CXXFLAGS='$CXXFLAGS'"
-if test "$with_server" != "no" -o "$THREAD_SAFE_CLIENT" != "no"
+if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE([THREAD], [1],
[Define if you want to have threaded code. This may be undef on client code])
# Avoid _PROGRAMS names
THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o mf_keycache.o"
AC_SUBST(THREAD_LOBJECTS)
-fi
-
-if test "$with_server" != "no"
-then
server_scripts="mysqld_safe mysql_install_db"
sql_server_dirs="strings mysys dbug extra regex"