summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortomas@whalegate.ndb.mysql.com <>2007-04-16 14:51:55 +0200
committertomas@whalegate.ndb.mysql.com <>2007-04-16 14:51:55 +0200
commit5ee4948dec5f3ee478d425cc6cbbc890faac04b6 (patch)
tree3ee4674c5f5e205b8b079d50f0baa63c5769f785 /configure.in
parente1f8ffa5b3443493e815f7e366057e9320bcfc19 (diff)
parentf1776dc5514f9274b1812d7c0ef5df8d39f4a661 (diff)
downloadmariadb-git-5ee4948dec5f3ee478d425cc6cbbc890faac04b6.tar.gz
Merge whalegate.ndb.mysql.com:/home/tomas/mysql-5.1-single-user
into whalegate.ndb.mysql.com:/home/tomas/mysql-5.1-new-maint
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index a46ba158d08..df9cd30ddbc 100644
--- a/configure.in
+++ b/configure.in
@@ -2258,11 +2258,10 @@ AC_SUBST(tools_dirs)
#MYSQL_CHECK_CPU
libmysqld_dirs=
-linked_libmysqld_targets=
if test "$with_embedded_server" = "yes"
then
libmysqld_dirs=libmysqld
- linked_libmysqld_targets="linked_libmysqld_sources linked_libmysqldex_sources"
+
AC_CONFIG_FILES(libmysqld/Makefile libmysqld/examples/Makefile)
# We can't build embedded library without building the server, because
# we depend on libmysys, libmystrings, libmyisam, etc.
@@ -2272,7 +2271,6 @@ fi
# mysql_config --libmysqld-libs will print out something like
# -L/path/to/lib/mysql -lmysqld -lmyisam -lmysys -lmystrings -ldbug ...
AC_SUBST([libmysqld_dirs])
-AC_SUBST([linked_libmysqld_targets])
# Shall we build the docs?
AC_ARG_WITH(docs,
@@ -2453,7 +2451,6 @@ thread_dirs=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
sql_client_dirs=
-linked_client_targets="linked_libmysql_sources"
AM_CONDITIONAL(THREAD_SAFE_CLIENT, test "$THREAD_SAFE_CLIENT" != "no")
@@ -2462,7 +2459,6 @@ then
sql_client_dirs="strings regex mysys dbug extra libmysql client"
else
sql_client_dirs="strings regex mysys dbug extra libmysql libmysql_r client"
- linked_client_targets="$linked_client_targets linked_libmysql_r_sources"
AC_CONFIG_FILES(libmysql_r/Makefile)
AC_DEFINE([THREAD_SAFE_CLIENT], [1], [Should the client be thread safe])
fi
@@ -2474,18 +2470,14 @@ AC_SUBST(CLIENT_THREAD_LIBS)
AC_SUBST(NON_THREADED_LIBS)
AC_SUBST(STATIC_NSS_FLAGS)
AC_SUBST(sql_client_dirs)
-AC_SUBST(linked_client_targets)
-# If configuring for NetWare, set up to link sources from and build the netware directory
+# If configuring for NetWare, build the netware directory
netware_dir=
-linked_netware_sources=
if expr "$SYSTEM_TYPE" : ".*netware.*" > /dev/null
then
netware_dir="netware"
- linked_netware_sources="linked_netware_sources"
fi
AC_SUBST(netware_dir)
-AC_SUBST(linked_netware_sources)
AM_CONDITIONAL(HAVE_NETWARE, test "$netware_dir" = "netware")
if test "$with_server" != "no" -o "$THREAD_SAFE_CLIENT" != "no"
@@ -2556,6 +2548,7 @@ AC_CONFIG_FILES(Makefile extra/Makefile mysys/Makefile dnl
tests/Makefile Docs/Makefile support-files/Makefile dnl
support-files/MacOSX/Makefile support-files/RHEL4-SElinux/Makefile dnl
mysql-test/Makefile dnl
+ debian/Makefile dnl
mysql-test/ndb/Makefile netware/Makefile sql-bench/Makefile dnl
include/mysql_version.h plugin/Makefile win/Makefile)