summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent/mysqldev@mysql.com/production.mysql.com>2007-06-20 14:00:28 +0200
committerunknown <kent/mysqldev@mysql.com/production.mysql.com>2007-06-20 14:00:28 +0200
commit9856f5f7b76da5abb0d442c87dd5e99a9d3ad4d8 (patch)
tree056b7c1835ab6b0a0b4ae1ccb5da7336ccc32250 /configure.in
parent85c7cedd591a9dc2e81705732eb09460f2e9ce39 (diff)
downloadmariadb-git-9856f5f7b76da5abb0d442c87dd5e99a9d3ad4d8.tar.gz
configure.in:
Added --with-system-type=<systype> and --with-machine-type=<machtype> options, to be able to override the one detected, for --version strings field.cc, field.h, listener.cc: C++ compatibility change for IBM VisualAge 6 and i5/OS configure.in: Added --with-system-type=<systype> and --with-machine-type=<machtype> options, to be able to override the one detected, for --version strings server-tools/instance-manager/listener.cc: C++ compatibility change for IBM VisualAge 6 and i5/OS sql/field.cc: C++ compatibility change for IBM VisualAge 6 and i5/OS sql/field.h: C++ compatibility change for IBM VisualAge 6 and i5/OS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e7e9aa58c9b..6cf8dbd4e47 100644
--- a/configure.in
+++ b/configure.in
@@ -100,14 +100,22 @@ AC_DEFINE_UNQUOTED([NDB_VERSION_STATUS], ["$NDB_VERSION_STATUS"],
# Canonicalize the configuration name.
-SYSTEM_TYPE="$host_vendor-$host_os"
-MACHINE_TYPE="$host_cpu"
+
+# Check whether --with-system-type or --without-system-type was given.
+AC_ARG_WITH(system-type,
+ [ --with-system-type Set the system type, like "sun-solaris10"],
+ [SYSTEM_TYPE="$withval"],
+ [SYSTEM_TYPE="$host_vendor-$host_os"])
+AC_ARG_WITH(machine-type,
+ [ --with-machine-type Set the machine type, like "powerpc"],
+ [MACHINE_TYPE="$withval"],
+ [MACHINE_TYPE="$host_cpu"])
AC_SUBST(SYSTEM_TYPE)
AC_DEFINE_UNQUOTED([SYSTEM_TYPE], ["$SYSTEM_TYPE"],
- [Name of system, eg solaris])
+ [Name of system, eg sun-solaris])
AC_SUBST(MACHINE_TYPE)
AC_DEFINE_UNQUOTED([MACHINE_TYPE], ["$MACHINE_TYPE"],
- [Machine type name, eg sun10])
+ [Machine type name, eg sparc])
# Detect intel x86 like processor
BASE_MACHINE_TYPE=$MACHINE_TYPE