summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <joerg@mysql.com>2004-12-30 16:44:50 +0100
committerunknown <joerg@mysql.com>2004-12-30 16:44:50 +0100
commitaf0f00d7262ce564da13499f05ef4ecee7a6dd05 (patch)
treeab48c96eee07abf187171bd7f11cb69fcb4ce8b6 /configure.in
parent53da5942a3df94966e7dbd2261d8acfb4350c6a7 (diff)
parent8a274fe015139d0c3762652fccc8ebae376d4f20 (diff)
downloadmariadb-git-af0f00d7262ce564da13499f05ef4ecee7a6dd05.tar.gz
Merge mysql.com:/M41/mysql-4.1 into mysql.com:/M41/push-4.1
configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f8b40872d3d..47447913168 100644
--- a/configure.in
+++ b/configure.in
@@ -2832,7 +2832,7 @@ thread_dirs=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
-sql_client_dirs="libmysql client"
+sql_client_dirs="libmysql strings regex client"
linked_client_targets="linked_libmysql_sources"
CLIENT_LIBS=$NON_THREADED_CLIENT_LIBS
if test "$THREAD_SAFE_CLIENT" != "no"
@@ -3014,6 +3014,20 @@ AC_SUBST(sql_server_dirs)
AC_SUBST(thread_dirs)
AC_SUBST(server_scripts)
+# Now that sql_client_dirs and sql_server_dirs are stable, determine the union.
+# Start with the (longer) server list, add each client item not yet present.
+sql_union_dirs=" $sql_server_dirs "
+for DIR in $sql_client_dirs
+do
+ if echo $sql_union_dirs | grep " $DIR " >/dev/null
+ then
+ : # already present, skip
+ else
+ sql_union_dirs="$sql_union_dirs $DIR "
+ fi
+done
+AC_SUBST(sql_union_dirs)
+
#if test "$with_posix_threads" = "no" -o "$with_mit_threads" = "yes"
#then
# MIT pthreads does now support connecting with unix sockets