summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg@mysql.com>2009-10-15 20:28:04 +0200
committerJoerg Bruehe <joerg@mysql.com>2009-10-15 20:28:04 +0200
commit44b0602263a92b91c91f2501bb736d7ac30cae34 (patch)
tree96df4f1638a3612394efa0b47493cbbe963e1106 /configure.in
parentaed976c6a7b8b18ab1acc723bcb2550909e2a7a5 (diff)
parenteaa55f45385ac53ab909b9b1ddb494116139c3a6 (diff)
downloadmariadb-git-44b0602263a92b91c91f2501bb736d7ac30cae34.tar.gz
Merge the bug fixes into the push tree.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d87adf395ed..d479088356b 100644
--- a/configure.in
+++ b/configure.in
@@ -2769,7 +2769,7 @@ server_scripts=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
-sql_client_dirs="strings regex mysys dbug libmysql"
+sql_client_dirs="strings mysys dbug extra regex libmysql"
AM_CONDITIONAL(THREAD_SAFE_CLIENT, test "$THREAD_SAFE_CLIENT" != "no")
@@ -2835,9 +2835,10 @@ AC_SUBST(mysql_plugin_defs)
# Now that sql_client_dirs and sql_server_dirs are stable, determine the union.
-# Start with the (longer) server list, add each client item not yet present.
-sql_union_dirs=" $sql_server_dirs "
-for DIR in $sql_client_dirs
+# We support client-only builds by "--without-server", but not vice versa,
+# so we start with the client list, then add each server item not yet present.
+sql_union_dirs=" $sql_client_dirs "
+for DIR in $sql_server_dirs
do
if echo " $sql_union_dirs " | grep " $DIR " >/dev/null
then