summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <mikael@c-870ae253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-04-19 21:22:35 -0400
committerunknown <mikael@c-870ae253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-04-19 21:22:35 -0400
commit629e03abffcc9ca2fde7d0312f09db1e78375be9 (patch)
tree9850b72f96536df551030ac68a61ccc9ae2ce51f /configure.in
parent310eeeb388631568d50baa2ef712042998fa6dc3 (diff)
parentb8461e8a3f27cc2949aa25c8d221e5016698ab0c (diff)
downloadmariadb-git-629e03abffcc9ca2fde7d0312f09db1e78375be9.tar.gz
Merge c-870ae253.1238-1-64736c10.cust.bredbandsbolaget.se:/home/pappa/clean-mysql-5.1-new
into c-870ae253.1238-1-64736c10.cust.bredbandsbolaget.se:/home/pappa/wl2826 configure.in: Auto merged dbug/dbug.c: Auto merged include/my_sys.h: Auto merged sql/ha_heap.cc: Auto merged sql/log.cc: Auto merged sql/mysql_priv.h: Auto merged sql/mysqld.cc: Auto merged sql/partition_info.h: Auto merged sql/sql_base.cc: Auto merged sql/sql_class.cc: Auto merged sql/sql_class.h: Auto merged sql/sql_partition.cc: Auto merged sql/sql_yacc.yy: Auto merged sql/table.cc: Auto merged BUILD/SETUP.sh: manual merge BUILD/compile-pentium-debug-max: manual merge sql/ha_ndbcluster.cc: manual merge sql/ha_ndbcluster.h: manual merge sql/ha_partition.cc: manual merge sql/ha_partition.h: manual merge sql/handler.h: manual merge sql/share/errmsg.txt: manual merge sql/sql_table.cc: manual merge sql/unireg.cc: manual merge
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6984f5b5f89..44e9d286e1f 100644
--- a/configure.in
+++ b/configure.in
@@ -666,6 +666,7 @@ else
AC_MSG_RESULT([no])
fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked
@@ -1608,6 +1609,21 @@ else
CXXFLAGS="$OPTIMIZE_CXXFLAGS -DDBUG_OFF $CXXFLAGS"
fi
+# If we should allow error injection tests
+AC_ARG_WITH(error-inject,
+ [ --with-error-inject Enable error injection in MySQL Server],
+ [ with_error_inject=$withval ],
+ [ with_error_inject=no ])
+
+if test $with_debug != "no"
+then
+ if test "$with_error_inject" = "yes"
+ then
+ AC_DEFINE([ERROR_INJECT_SUPPORT], [1],
+ [Enable error injection in MySQL Server])
+ fi
+fi
+
AC_ARG_WITH([fast-mutexes],
AC_HELP_STRING([--with-fast-mutexes],
[Compile with fast mutexes (default is disabled)]),