summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2002-10-01 21:16:27 +0200
committerunknown <lenz@mysql.com>2002-10-01 21:16:27 +0200
commitc506c395b23979d7b8e9cbac24e3a0cc31bf1116 (patch)
treee996b2a1d20ff73a44aa4657bbd9ca624756d8e4 /configure.in
parentc525a541b7de61041b21a4129337a114c7b353de (diff)
downloadmariadb-git-c506c395b23979d7b8e9cbac24e3a0cc31bf1116.tar.gz
- Tagged ChangeSet 1.1321 as mysql-4.0.4
- added some missing changelog entries to the 4.0.5 changelog - applied small fix to configure.in from monty (already applied manually to configure.in of the 4.0.4 release source files - not relevant for normal builds anyway) Docs/manual.texi: - added missing changelog entries - added the 4.0.4 release date configure.in: - bumped up version number to 4.0.5-beta, now that the 4.0.4 builds are done - applied fix from Monty to be able to build shared libraries even when the the static NSS libraries are installed. This patch has already been applied to the released 4.0.4 sources to work around a local build problem, but has not been checked in yet.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 5 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 8c3f06445c2..79f97a83ff3 100644
--- a/configure.in
+++ b/configure.in
@@ -4,7 +4,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(sql/mysqld.cc)
AC_CANONICAL_SYSTEM
# The Docs Makefile.am parses this line!
-AM_INIT_AUTOMAKE(mysql, 4.0.4-beta)
+AM_INIT_AUTOMAKE(mysql, 4.0.5-beta)
AM_CONFIG_HEADER(config.h)
PROTOCOL_VERSION=10
@@ -481,7 +481,7 @@ AC_ARG_WITH(other-libc,
# we need special flags, but we will have to add those later
STATIC_NSS_FLAGS="-lc -lnss_files -lnss_dns -lresolv"
STATIC_NSS_FLAGS="$STATIC_NSS_FLAGS $STATIC_NSS_FLAGS"
- OTHER_LIBC_LIB="-L$other_libc_lib"
+ OTHER_LIBC_LIB="-static -L$other_libc_lib"
static_nss=1
else
# this is a dirty hack. We if we detect static nss glibc in the special
@@ -2241,10 +2241,7 @@ then
AC_DEFINE(THREAD_SAFE_CLIENT)
fi
-if test "$static_nss" = "1"
-then
- CLIENT_LIBS="$CLIENT_LIBS $STATIC_NSS_FLAGS"
-fi
+CLIENT_LIBS="$CLIENT_LIBS $STATIC_NSS_FLAGS"
AC_SUBST(CLIENT_LIBS)
AC_SUBST(sql_client_dirs)
@@ -2391,11 +2388,8 @@ fi
# I know to add the static NSS magic if we have static NSS libraries with
# glibc - Sasha
-if test "$static_nss" = "1"
-then
- LDFLAGS="$LDFLAGS -static $OTHER_LIBC_LIB"
- LIBS="$LIBS $STATIC_NSS_FLAGS"
-fi
+LDFLAGS="$LDFLAGS $OTHER_LIBC_LIB"
+LIBS="$LIBS $STATIC_NSS_FLAGS"
AC_SUBST(sql_server_dirs)
AC_SUBST(thread_dirs)