summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2002-10-01 21:57:10 +0200
committerunknown <lenz@mysql.com>2002-10-01 21:57:10 +0200
commit95baa1c1ed77fba8d7235be1c9c7d05cd322f5cb (patch)
tree1498636efd6a0835df79c54a9044e3f8215d61cb /configure.in
parent985e4a8eaa6a9f691317abbae8c65809c0fd75fb (diff)
downloadmariadb-git-95baa1c1ed77fba8d7235be1c9c7d05cd322f5cb.tar.gz
- Applied required modifications for automake 1.5
- some additional small fixes - added "depcomp" for automake 1.5 acinclude.m4: - Removed AC_SYS_LARGEFILE (is in autoconf since v2.50) config.guess: - applied diffs from config.guess of automake 1.5 config.sub: - applied diffs from config.sub of automake 1.5 configure.in: - adapted for automake 1.5 - added AM_PROG_AS - replaced MYSQL_SYS_LARGEFILE with AC_SYS_LARGEFILE (is in autoconf since v2.50) dbug/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy extra/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy heap/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy include/my_global.h: - fix for PPC64 install-sh: - applied diffs from install-sh of automake 1.5 isam/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy libmysql_r/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy libmysqld/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy ltconfig: - small correction for new libtool ltmain.sh: - applied diffs from ltmain.sh of libtool 1.4.2 merge/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy missing: - applied diffs from missing of automake 1.5 myisam/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy myisammrg/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy mysys/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy regex/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy sql/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy strings/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy tools/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy vio/Makefile.am: - removed OMIT_DEPENDENCIES to make automake 1.5 happy
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 79f97a83ff3..417e28b29d4 100644
--- a/configure.in
+++ b/configure.in
@@ -446,6 +446,9 @@ AC_MSG_RESULT("$CHECK_PID")
# We need a ANSI C compiler
AM_PROG_CC_STDC
+# We need an assembler, too
+AM_PROG_AS
+
if test "$am_cv_prog_cc_stdc" = "no"
then
AC_MSG_ERROR([MySQL requires a ANSI C compiler (and a C++ compiler). Try gcc. See the Installation chapter in the Reference Manual.])
@@ -668,8 +671,7 @@ else
AC_MSG_RESULT([no])
fi
-# Use Paul Eggerts macros from GNU tar to check for large file support.
-MYSQL_SYS_LARGEFILE
+AC_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked
AC_TYPE_SIZE_T