summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-07-23 17:18:36 -0300
committerDavi Arnaut <davi.arnaut@oracle.com>2010-07-23 17:18:36 -0300
commitecd4a294a5d0ef4f0191993352bb0c1290e3c132 (patch)
treee39190b7222d99ca43735545cd66a9090e96e4ee /configure.in
parente001970cc7ca527ea7e81647d2fe4b6b5afd4478 (diff)
downloadmariadb-git-ecd4a294a5d0ef4f0191993352bb0c1290e3c132.tar.gz
WL#5498: Remove dead and unused source code
Remove wrappers around inline -- static inline is used without wrappers throughout the source code. We rely on the compiler or linker to eliminate unused static functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a2f0c432681..f90a68b241d 100644
--- a/configure.in
+++ b/configure.in
@@ -1210,7 +1210,6 @@ case $SYSTEM_TYPE in
# Fixes for HPUX 11.0 compiler
if test "$ac_cv_prog_gcc" = "no"
then
- CFLAGS="$CFLAGS -DHAVE_BROKEN_INLINE"
# set working flags first in line, letting override it (i. e. for debug):
CXXFLAGS="+O2 $CXXFLAGS"
MAX_C_OPTIMIZE=""
@@ -1997,6 +1996,9 @@ fi
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_C_INLINE
+AS_IF([test "x$ac_cv_c_inline" = "xno"],
+ [AC_MSG_WARN([The C compiler does not support inline. Beware that unused
+ functions might not be eliminated the object files.])])
AC_TYPE_OFF_T
AC_STRUCT_ST_RDEV
AC_HEADER_TIME