summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChad MILLER <chad@mysql.com>2009-05-06 09:06:32 -0400
committerChad MILLER <chad@mysql.com>2009-05-06 09:06:32 -0400
commit128afdc3e5d06381f525e0d9cdc2df7c497e886c (patch)
treeb7a5df1540af07a49f7d577804919b7027fc4edf /configure.in
parent0f95bd31058f21f0872191eac49809622725564d (diff)
parent9d58239dea8c615a10a0939e34d052b22808e75f (diff)
downloadmariadb-git-128afdc3e5d06381f525e0d9cdc2df7c497e886c.tar.gz
Merge community up to enterprise, thus ending the community-server
adventure.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in41
1 files changed, 39 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bd201aa9d26..e4d7e0975d9 100644
--- a/configure.in
+++ b/configure.in
@@ -661,7 +661,6 @@ then
fi
fi
-
AC_ARG_WITH(server-suffix,
[ --with-server-suffix Append value to the version string.],
[ MYSQL_SERVER_SUFFIX=`echo "$withval" | sed -e 's/^\(...................................\)..*$/\1/'` ],
@@ -724,6 +723,45 @@ else
AC_MSG_RESULT([no])
fi
+AC_MSG_CHECKING(whether features provided by the user community should be included.)
+AC_ARG_ENABLE(community-features,
+ AC_HELP_STRING(
+ [--enable-community-features],
+ [Enable additional features provided by the user community.]),
+ [ ENABLE_COMMUNITY_FEATURES=$enableval ],
+ [ ENABLE_COMMUNITY_FEATURES=no ]
+ )
+
+if test "$ENABLE_COMMUNITY_FEATURES" = "yes"
+then
+ AC_DEFINE([COMMUNITY_SERVER], [1],
+ [Whether features provided by the user community should be included])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+# Add query profiler
+AC_MSG_CHECKING(whether query profiling should be included)
+AC_ARG_ENABLE(profiling,
+ AS_HELP_STRING([--enable-profiling], [Add query-profiling code.]),
+ [ ENABLED_PROFILING=$enableval ],
+ [ ENABLED_PROFILING=no ])
+
+if test "$ENABLED_PROFILING" = "yes"
+then
+ if test "$ENABLE_COMMUNITY_FEATURES" = "yes";
+ then
+ AC_DEFINE([ENABLED_PROFILING], [1], [If SHOW PROFILE should be enabled])
+ AC_MSG_RESULT([yes])
+ else
+ ENABLED_PROFILING="no"
+ AC_MSG_RESULT([no, overridden because community-features disabled])
+ AC_MSG_ERROR([This is almost certainly wrong. Add --enable-community-features or remove --enable-profiling .])
+ fi
+else
+ AC_MSG_RESULT([no])
+fi
# Use this to set the place used for unix socket used to local communication.
AC_ARG_WITH(unix-socket-path,
@@ -1177,7 +1215,6 @@ case $SYSTEM_TYPE in
fi
;;
*darwin*)
- AC_DEFINE([DEFAULT_SKIP_THREAD_PRIORITY], [1], [default to skip thread priority])
if test "$ac_cv_prog_gcc" = "yes"
then
FLAGS="-D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT"