summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@narttu.mysql.fi>2003-02-27 17:35:51 +0200
committerunknown <monty@narttu.mysql.fi>2003-02-27 17:35:51 +0200
commite6dad7043682a140ed907b3dd5a79904603fde33 (patch)
tree9a78565a91c6598a50921f763c99dee6cfe2c4d1 /configure.in
parentbe9a61f17541339a2d5ac71f48cf2cb1cb78d305 (diff)
downloadmariadb-git-e6dad7043682a140ed907b3dd5a79904603fde33.tar.gz
Added detection if pthread_attr_getstacksize() exists
Fixed bug in RAND() usage in mysqlbinlog configure.in: Added detection if pthread_attr_getstacksize() exists include/thr_lock.h: Fixed wrong comment sql/log_event.cc: Fixed bug in RAND() usage in mysqlbinlog sql/mysqld.cc: Portablity fix sql/repl_failsafe.cc: Set host_or_ip for system threads (to make other code simpler) sql/slave.cc: Set host_or_ip for system threads (to make other code simpler) sql/sql_class.cc: Set host_or_ip for system threads (to make other code simpler) sql/sql_insert.cc: Set host_or_ip for system threads (to make other code simpler) sql/sql_show.cc: Set host_or_ip for system threads (to make other code simpler)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b5cf42a7a2e..56a3dbd8bd1 100644
--- a/configure.in
+++ b/configure.in
@@ -1796,6 +1796,7 @@ AC_CHECK_FUNCS(alarm bmove \
sigset sigthreadmask pthread_sigmask pthread_setprio pthread_setprio_np \
pthread_setschedparam pthread_attr_setprio pthread_attr_setschedparam \
pthread_attr_create pthread_getsequence_np pthread_attr_setstacksize \
+ pthread_attr_getstacksize \
pthread_condattr_create rwlock_init pthread_rwlock_rdlock \
fchmod getpass getpassphrase initgroups mlockall)