summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2022-03-11 09:26:42 +0200
committerMarko Mäkelä <marko.makela@mariadb.com>2022-03-11 09:26:42 +0200
commit22d2df8c6bd00c5f232b959197da95c9eba3120e (patch)
tree18be5bfcde0f706233e8a1da8226ce5fc54cb8b4 /debian/autobake-deb.sh
parent77c184df7c056da7364e606ac977cc2d3cd826ad (diff)
parent1766a18e06a056155031dabefb88ce7f201ad921 (diff)
downloadmariadb-git-22d2df8c6bd00c5f232b959197da95c9eba3120e.tar.gz
Merge 10.3 into 10.4
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index a8b1010643b..9452ef4f458 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -42,6 +42,14 @@ GCCVERSION=$(gcc -dumpfullversion -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g
# Debian policy and targeting Debian Sid. Then case-by-case run in autobake-deb.sh
# tests for backwards compatibility and strip away parts on older builders.
+CODENAME="$(lsb_release -sc)"
+case "${CODENAME}" in
+ stretch)
+ # MDEV-28022 libzstd-dev-1.1.3 minimum version
+ sed -i -e '/libzstd-dev/d' debian/control
+ ;;
+esac
+
# If libcrack2 (>= 2.9.0) is not available (before Debian Jessie and Ubuntu Trusty)
# clean away the cracklib stanzas so the package can build without them.
if ! apt-cache madison libcrack2-dev | grep 'libcrack2-dev *| *2\.9' >/dev/null 2>&1
@@ -72,13 +80,6 @@ then
sed '/mariadb-service-convert/d' -i debian/mariadb-server-10.4.install
fi
-# If libzstd-dev is not available (before Debian Stretch and Ubuntu Xenial)
-# remove the dependency from server and rocksdb so it can build properly
-if ! apt-cache madison libzstd-dev | grep 'libzstd-dev' >/dev/null 2>&1
-then
- sed '/libzstd-dev/d' -i debian/control
-fi
-
# The binaries should be fully hardened by default. However TokuDB compilation seems to fail on
# Debian Jessie and older and on Ubuntu Xenial and older with the following error message:
# /usr/bin/ld.bfd.real: /tmp/ccOIwjFo.ltrans0.ltrans.o: relocation R_X86_64_PC32 against symbol
@@ -139,7 +140,6 @@ source ./VERSION
UPSTREAM="${MYSQL_VERSION_MAJOR}.${MYSQL_VERSION_MINOR}.${MYSQL_VERSION_PATCH}${MYSQL_VERSION_EXTRA}"
PATCHLEVEL="+maria"
LOGSTRING="MariaDB build"
-CODENAME="$(lsb_release -sc)"
EPOCH="1:"
dch -b -D ${CODENAME} -v "${EPOCH}${UPSTREAM}${PATCHLEVEL}~${CODENAME}" "Automatic build with ${LOGSTRING}."