summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-04-13 10:26:01 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2021-04-13 10:26:01 +0300
commit6e6318b29b446f76f01f2ef65d1460870b607d2a (patch)
tree8c22bb7661b77c91b28532ddd7c150d4bf010146 /debian/autobake-deb.sh
parent450c017c2d9e490d92c949d5164b4a99b6b3f5db (diff)
parente262eb165c197083df9f4986ab54c5b2dcbd6290 (diff)
downloadmariadb-git-6e6318b29b446f76f01f2ef65d1460870b607d2a.tar.gz
Merge 10.2 into 10.3
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index e6e16105c70..ae9b77a382b 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -111,6 +111,15 @@ then
sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
fi
+# From Debian Stretch/Ubuntu Bionic onwards dh-systemd is just an empty
+# transitional metapackage and the functionality was merged into debhelper.
+# In Ubuntu Hirsute is was completely removed, so it can't be referenced anymore.
+# Keep using it only on Debian Jessie and Ubuntu Xenial.
+if apt-cache madison dh-systemd | grep 'dh-systemd' >/dev/null 2>&1
+then
+ sed 's/debhelper (>= 9.20160709~),/debhelper (>= 9), dh-systemd,/' -i debian/control
+fi
+
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then