summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@mariadb.org>2016-10-26 02:12:18 +0300
committerOtto Kekäläinen <otto@mariadb.org>2016-10-27 18:42:17 +0300
commit0668e6ba49f0004e7f137b22c912cea74069d851 (patch)
tree711253cd5c311f083f0207a167006388647a6664 /debian/autobake-deb.sh
parent7f570bef1e3a6b19925bf7e58e02b975548039eb (diff)
downloadmariadb-git-0668e6ba49f0004e7f137b22c912cea74069d851.tar.gz
Travis-CI: skip building mariadb-test packages to speed up build
The build must stay under the Travis-CI 50 minute limit. Currently they often exceed, and the huge test suite is the single most long step in moving/packaging files, so remove it on Travis-CI automatically.
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index c463164ca16..2a5fe015924 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -21,6 +21,13 @@ then
export DEB_BUILD_OPTIONS="nocheck"
fi
+# Don't include test suite package on Travis-CI to make the build time shorter
+if [[ $TRAVIS ]]
+then
+ sed '/Package: mariadb-test-data/,+26d' -i debian/control
+ sed '/Package: mariadb-test/,+34d' -i debian/control
+fi
+
export MARIADB_OPTIONAL_DEBS=""
# Find major.minor version.