summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2018-01-04 09:22:59 +0200
committerMarko Mäkelä <marko.makela@mariadb.com>2018-01-04 09:22:59 +0200
commit145ae15a33210e13d33d6f41b145b3f04cab2263 (patch)
tree02810e3c0d629f7d7def2dbc663154cbdb53242f /debian/rules
parentacd2862e65a6555fba6065b7b4ded8513e2ce37c (diff)
parent1a1bda2222e0c2ab41baed1510f6fbca80c20d31 (diff)
downloadmariadb-git-145ae15a33210e13d33d6f41b145b3f04cab2263.tar.gz
Merge bb-10.2-ext into 10.3
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 5 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 212e2764521..76433d47576 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,11 +45,6 @@ else
TESTSUITE_FAIL_CMD:=exit 1
endif
-# Skip TokuDB if arch is not amd64
-ifneq ($(ARCH), amd64)
- CMAKEFLAGS += -DWITHOUT_TOKUDB=true
-endif
-
# Add support for verbose builds
MAKEFLAGS += VERBOSE=1
@@ -119,19 +114,15 @@ override_dh_auto_install:
dh_testdir
dh_testroot
- # If TokuDB plugin was not built skip the package
- [ -f $(BUILDDIR)/storage/tokudb/ha_tokudb.so ] || sed -i -e "/Package: mariadb-plugin-tokudb/,+16d" debian/control
-
- # If Mroonga plugin was not built skip the package
- [ -f $(BUILDDIR)/storage/mroonga/ha_mroonga.so ] || sed -i -e "/Package: mariadb-plugin-mroonga/,+15d" debian/control
+# Skip TokuDB if arch is not amd64
+ifneq ($(ARCH), amd64)
+ sed -i -e "/Package: mariadb-plugin-tokudb/,+18d" debian/control
+endif
# If libthrift-dev was available (manually installed, as it is
# not in Debian) and ha_cassandra.so was thus built, create package,
# otherwise skip it.
- [ -f $(BUILDDIR)/storage/cassandra/ha_cassandra.so ] || sed -i -e "/Package: mariadb-plugin-cassandra/,+18d" debian/control
-
- # If Spider plugin was not built skip the package
- [ -f $(BUILDDIR)/storage/spider/ha_spider.so ] || sed -i -e "/Package: mariadb-plugin-spider/,+16d" debian/control
+ [ -f $(BUILDDIR)/storage/cassandra/ha_cassandra.so ] || sed -i -e "/Package: mariadb-plugin-cassandra/,+20d" debian/control
# Copy systemd files to a location available for dh_installinit
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.3.mariadb.service