summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@mariadb.org>2016-10-29 02:17:14 +0300
committerOtto Kekäläinen <otto@mariadb.org>2016-10-29 02:17:14 +0300
commit02a6f61a8ab651c0210bf05b4b697849e985e5e7 (patch)
tree13e13bccd01c15a3d2ffc2a000cc78bfcade24ee /debian/rules
parentbfda961c86849a4a6fea4b6d71a38266758b1bc9 (diff)
downloadmariadb-git-02a6f61a8ab651c0210bf05b4b697849e985e5e7.tar.gz
Deb: delete runnable files we don't want to have in the test data package
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c14076ed67b..eca59c5b1f7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -132,6 +132,11 @@ override_dh_auto_install:
# make install
cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP)
+ # Delete runnable files we don't want to have in the test data package.
+ # This avoids triggering multiple Lintian errors.
+ rm -rf $(TMP)/usr/share/mysql/mysql-test/plugin/tokudb/tokudb/*.py
+ rm -rf $(TMP)/usr/share/mysql/mysql-test/plugin/tokudb/tokudb/t/*.py
+
# nm numeric soft is not enough, therefore extra sort in command
# to satisfy Debian reproducible build requirements
nm --defined-only $(BUILDDIR)/sql/mysqld | LC_ALL=C sort | gzip -n -9 > $(TMP)/usr/share/doc/mariadb-server-10.2/mysqld.sym.gz