summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSergey Vojtovich <svoj@mariadb.org>2015-09-28 15:08:09 +0400
committerSergey Vojtovich <svoj@mariadb.org>2015-10-12 17:51:49 +0200
commit6346d1de2fdaa8a8359082871eac49402cb0e472 (patch)
tree62a057a2b8ab0b24bc242461522017e333fe741f /debian/rules
parent20c2ae39db3dd0ec4c337a9b0bd2bf4481b61e49 (diff)
downloadmariadb-git-6346d1de2fdaa8a8359082871eac49402cb0e472.tar.gz
MDEV-427/MDEV-5713 Add systemd script with notify functionality
After review/QA fixes.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 3 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index e16fb6436ca..1c824626dca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -180,12 +180,6 @@ install: build
install -m 0644 $(builddir)/Docs/INFO_SRC $(TMP)/usr/share/doc/mariadb-server-10.1/INFO_SRC
install -m 0644 $(builddir)/Docs/INFO_BIN $(TMP)/usr/share/doc/mariadb-server-10.1/INFO_BIN
- # systemd helpers
- install -m 0755 scripts/mariadb-service-convert $(TMP)/usr/bin/
- install -d $(TMP)/etc/systemd/system/mariadb@bootstrap.service.d/
- install -m 0644 $(BUILDDIR)/support-files/mariadb-bootstrap.conf \
- $(TMP)/etc/systemd/system/mariadb@bootstrap.service.d/wsrep-new-cluster.conf
-
# mariadb-test
mv $(TMP)/usr/mysql-test $(TMP)/usr/share/mysql
@@ -221,10 +215,7 @@ binary-indep: build install
dh_installexamples -i
dh_installmenu -i
dh_installlogrotate -i
- dh_systemd_enable -i support-files/mariadb.service
- dh_systemd_enable --no-enable support-files/mariadb@.service
dh_installinit -i
- dh_systemd_start -i --restart-after-upgrade mariadb.service
dh_installcron -i
dh_installman -i
dh_installinfo -i
@@ -250,9 +241,12 @@ binary-arch: build install
dh_installexamples -a
dh_installmenu -a
dh_installlogrotate -a --name mysql-server
+ if [ -x /usr/bin/dh_systemd_enable -a -f debian/mariadb-server-10.1/lib/systemd/system/mariadb.service ]; then dh_systemd_enable -pmariadb-server-10.1 mariadb.service; fi
+ if [ -x /usr/bin/dh_systemd_enable -a -f debian/mariadb-server-10.1/lib/systemd/system/mariadb@.service ]; then dh_systemd_enable --no-enable -pmariadb-server-10.1 mariadb@.service; fi
# Start mysql in runlevel 19 before 20 where apache, proftpd etc gets
# started which might depend on a running database server.
dh_installinit -a --name=mysql -- defaults 19 21
+ if [ -x /usr/bin/dh_systemd_start -a -f debian/mariadb-server-10.1/lib/systemd/system/mariadb.service ]; then dh_systemd_start -pmariadb-server-10.1 --restart-after-upgrade mariadb.service; fi
dh_installcron -a --name mysql-server
dh_installman -a
dh_installinfo -a