summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2017-12-03 02:17:12 +0100
committerSergei Golubchik <serg@mariadb.org>2017-12-25 12:00:51 +0100
commit9631d933fbc2ec998746d49e1c2134d57947705a (patch)
tree9443aa656c44af764fab94755cf674e7e1fcd8d4 /debian
parentf0f3b6549a5924a194e8ce56a0c47443acbb506e (diff)
downloadmariadb-git-9631d933fbc2ec998746d49e1c2134d57947705a.tar.gz
debian: don't be smart about skipping plugins
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules17
1 files changed, 4 insertions, 13 deletions
diff --git a/debian/rules b/debian/rules
index 2f385b26455..2041371a409 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,11 +45,6 @@ else
TESTSUITE_FAIL_CMD:=exit 1
endif
-# Skip TokuDB if arch is not amd64
-ifneq ($(ARCH), amd64)
- CMAKEFLAGS += -DWITHOUT_TOKUDB=true
-endif
-
# Add support for verbose builds
MAKEFLAGS += VERBOSE=1
@@ -119,20 +114,16 @@ override_dh_auto_install:
dh_testdir
dh_testroot
- # If TokuDB plugin was not built skip the package
- [ -f $(BUILDDIR)/storage/tokudb/ha_tokudb.so ] || sed -i -e "/Package: mariadb-plugin-tokudb/,+14d" debian/control
-
- # If Mroonga plugin was not built skip the package
- [ -f $(BUILDDIR)/storage/mroonga/ha_mroonga.so ] || sed -i -e "/Package: mariadb-plugin-mroonga/,+13d" debian/control
+# Skip TokuDB if arch is not amd64
+ifneq ($(ARCH), amd64)
+ sed -i -e "/Package: mariadb-plugin-tokudb/,+14d" debian/control
+endif
# If libthrift-dev was available (manually installed, as it is
# not in Debian) and ha_cassandra.so was thus built, create package,
# otherwise skip it.
[ -f $(BUILDDIR)/storage/cassandra/ha_cassandra.so ] || sed -i -e "/Package: mariadb-plugin-cassandra/,+16d" debian/control
- # If Spider plugin was not built skip the package
- [ -f $(BUILDDIR)/storage/spider/ha_spider.so ] || sed -i -e "/Package: mariadb-plugin-spider/,+14d" debian/control
-
# Copy systemd files to a location available for dh_installinit
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.2.mariadb.service
cp $(BUILDDIR)/support-files/mariadb@.service debian/mariadb-server-10.2.mariadb@.service