summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2020-06-03 09:52:53 +0200
committerOleksandr Byelkin <sanja@mariadb.com>2020-06-19 21:04:17 +0200
commitc2b12c554e3404479e8260a31d2669209d777411 (patch)
tree6c9f69654126106716ec7ed9247147a1ce2ed617 /debian
parent09e8c77cad3daf705cf70a20b5f8e724bcb89fca (diff)
downloadmariadb-git-c2b12c554e3404479e8260a31d2669209d777411.tar.gz
build deb packages for columnstore
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh10
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules10
3 files changed, 11 insertions, 10 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 27a5def0792..e838f5964b2 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -31,7 +31,7 @@ then
sed 's|DINSTALL_MYSQLTESTDIR=share/mysql/mysql-test|DINSTALL_MYSQLTESTDIR=false|' -i debian/rules
# Also skip building RocksDB, Mroonga etc to save even more time and disk space
- sed 's|-DDEB|-DPLUGIN_MROONGA=NO -DPLUGIN_ROCKSDB=NO -DPLUGIN_SPIDER=NO -DPLUGIN_OQGRAPH=NO -DPLUGIN_PERFSCHEMA=NO -DPLUGIN_SPHINX=NO -DDEB|' -i debian/rules
+ sed 's|-DDEB|-DPLUGIN_MROONGA=NO -DPLUGIN_SPIDER=NO -DPLUGIN_OQGRAPH=NO -DPLUGIN_PERFSCHEMA=NO -DPLUGIN_SPHINX=NO -DDEB|' -i debian/rules
fi
# Convert gcc version to numberical value. Format is Mmmpp where M is Major
@@ -75,6 +75,7 @@ fi
if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]] || [[ $TRAVIS ]]
then
sed '/Package: mariadb-plugin-rocksdb/,/^$/d' -i debian/control
+ sed -i 's|-DPLUGIN_ROCKSDB=YES|-DPLUGIN_ROCKSDB=NO|' debian/rules
fi
# If libpcre2-dev is not available (before Debian Stretch and Ubuntu Xenial)
@@ -94,10 +95,11 @@ then
sed -i -e "/Package: libmariadbd-dev/,/^$/d" debian/control
fi
-# Don't package ColumnStore if it wasn't turned on to build
-if [[ $CMAKEFLAGS != *"COLUMNSTORE=YES"* ]]
+if [[ $TRAVIS ]] || ! [[ $(arch) =~ 86 ]]
then
- sed -i -e "/Package: mariadb-plugin-columnstore/,/^$/d" debian/control
+ sed -i -e "/Package: mariadb-plugin-columnstore/,/^$/d" debian/control
+ sed -i '/flex/d' debian/control
+ sed -i 's|-DPLUGIN_COLUMNSTORE=YES|-DPLUGIN_COLUMNSTORE=NO|' debian/rules
fi
# Adjust changelog, add new version
diff --git a/debian/control b/debian/control
index 20ac61f20a3..db49dd1ed35 100644
--- a/debian/control
+++ b/debian/control
@@ -9,6 +9,7 @@ Build-Depends: bison,
dh-apparmor,
dh-exec,
dh-systemd,
+ flex,
gdb,
libaio-dev [linux-any],
libboost-dev,
diff --git a/debian/rules b/debian/rules
index a5f49c732a9..61717416e35 100755
--- a/debian/rules
+++ b/debian/rules
@@ -39,10 +39,6 @@ else
TESTSUITE_FAIL_CMD:=exit 1
endif
-ifeq (32,$(DEB_HOST_ARCH_BITS))
- CMAKEFLAGS += -DWITHOUT_ROCKSDB=true
-endif
-
# Add extra flag to avoid WolfSSL code crashing the entire mariadbd on s390x. This
# can be removed once upstream has made the code s390x compatible, see
# https://jira.mariadb.org/browse/MDEV-21705 and
@@ -85,8 +81,10 @@ endif
-DSYSTEM_TYPE="debian-$(DEB_HOST_GNU_SYSTEM)" \
-DCMAKE_SYSTEM_PROCESSOR=$(DEB_HOST_ARCH) \
-DBUILD_CONFIG=mysql_release \
- -DWITHOUT_TOKUDB=true \
- -DWITHOUT_CASSANDRA=true \
+ -DPLUGIN_TOKUDB=NO \
+ -DPLUGIN_CASSANDRA=NO \
+ -DPLUGIN_COLUMNSTORE=YES \
+ -DPLUGIN_ROCKSDB=YES \
-DPLUGIN_AWS_KEY_MANAGEMENT=NO \
-WITH_EMBEDDED_SERVER=OFF \
-DDEB=$(DEB_VENDOR) ..'