summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@mariadb.org>2018-04-11 22:17:46 +0300
committerOtto Kekäläinen <otto@mariadb.org>2018-05-28 11:32:21 +0300
commit0a2ef601e017ff77f7920f84e9fe1e4eb9f1ae71 (patch)
tree3effaa46129c119a077e07cdf31ac32e8b66c29c /debian
parent548ec3a088a2444881e1245a237f81cea1671969 (diff)
downloadmariadb-git-0a2ef601e017ff77f7920f84e9fe1e4eb9f1ae71.tar.gz
Deb: Skip building RocksDB, TokuDB and using jemalloc on certain archs
(This change matches how debian/rules is in downstream Debian.org)
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 4c29038cd2f..f5e2c21a126 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,6 +45,22 @@ else
TESTSUITE_FAIL_CMD:=exit 1
endif
+ifeq (32,$(DEB_HOST_ARCH_BITS))
+ CMAKEFLAGS += -DWITHOUT_ROCKSDB=true
+endif
+
+# Skip TokuDB if arch is not amd64 (also disable for kfreebsd-amd64 as it FTBFS)
+# Skipped on the x32 ABI too; untested, but unlikely to work given i386 is not
+# supported.
+ifneq ($(DEB_HOST_ARCH),amd64)
+ CMAKEFLAGS += -DWITHOUT_TOKUDB=true
+endif
+
+# Disable jemalloc on mips* due to #843926
+ifneq (,$(filter $(DEB_HOST_ARCH), mips mipsel mips64 mips64el))
+ CMAKEFLAGS += -DWITH_JEMALLOC=no
+endif
+
# Add support for verbose builds
MAKEFLAGS += VERBOSE=1