summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorVicențiu Ciorbaru <vicentiu@mariadb.org>2017-03-26 18:13:29 +0300
committerVicențiu Ciorbaru <vicentiu@mariadb.org>2017-03-26 18:38:20 +0300
commitc29336f2b0c99d39979609374b8673573475696f (patch)
treec674e1bbbf410554551c63ee6894bd91c99be3fc /debian
parent7ebb81be1d59eaea1697daca7842fc1cfb5b9609 (diff)
downloadmariadb-git-c29336f2b0c99d39979609374b8673573475696f.tar.gz
Skip rocksdb on debian i386 and when gcc version is < 4.8
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 198cba8a467..bdb5535da99 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -72,6 +72,16 @@ then
sed '/mariadb-service-convert/d' -i debian/mariadb-server-10.2.install
fi
+# Convert gcc version to numberical value. Format is Mmmpp where M is Major
+# version, mm is minor version and p is patch.
+GCCVERSION=$(gcc -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' -e 's/\.\([0-9]\)/0\1/g' -e 's/^[0-9]\{3,4\}$/&00/')
+# Don't build rocksdb package if gcc version is less than 4.8 or we are running on
+# x86 32 bit.
+if [ $GCCVERSION -lt 40800 ] || [ $(uname -i) -eq "i386" ] || [$(uname -i) -eq "i486"]
+then
+ sed '/Package: mariadb-plugin-rocksdb/,+7d' -i debian/control
+fi
+
# Adjust changelog, add new version
echo "Incrementing changelog and starting build scripts"