summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniel Black <daniel@mariadb.org>2020-10-06 17:07:52 +1100
committerDaniel Black <daniel@mariadb.org>2020-10-06 22:22:03 +1100
commitb3a9fbdbab5d29408a637d9d2422a75876f76756 (patch)
tree4b098c0cc2fb13aabba98aabaacfcf312763fa66 /debian
parent350c9eb705477afef876e982201ad55dcc65bc9c (diff)
downloadmariadb-git-b3a9fbdbab5d29408a637d9d2422a75876f76756.tar.gz
travis: 10.2 only - make faster
Remove from debian build: * tokudb * mroonga * spider * ograph * embedded server Add ccache to debian build. Backport 10.3 changes to autobake-deb that make travis faster. Merge instructions: Drop this commit on merge to 10.3
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 687f2356153..ddef69bb350 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -26,6 +26,12 @@ then
# Don't include test suite package on Travis-CI to make the build time shorter
sed '/Package: mariadb-test-data/,/^$/d' -i debian/control
sed '/Package: mariadb-test/,/^$/d' -i debian/control
+ sed '/Package: mariadb-plugin-tokudb/,/^$/d' -i debian/control
+ sed '/Package: mariadb-plugin-mroonga/,/^$/d' -i debian/control
+ sed '/Package: mariadb-plugin-spider/,/^$/d' -i debian/control
+ sed '/Package: mariadb-plugin-oqgraph/,/^$/d' -i debian/control
+ export MYSQL_COMPILER_LAUNCHER=ccache
+ sed 's|-DDEB|-DPLUGIN_TOKUDB=NO -DPLUGIN_MROONGA=NO -DPLUGIN_SPIDER=NO -DPLUGIN_OQGRAPH=NO -DPLUGIN_PERFSCHEMA=NO -WITH_EMBEDDED_SERVER=OFF -DDEB|' -i debian/rules
fi