summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2018-06-30 16:39:20 +0200
committerSergei Golubchik <serg@mariadb.org>2018-06-30 16:39:20 +0200
commit36e59752e7fc70bc5179a3d730b5ce3ee58e4e30 (patch)
tree0d3e30ce973b2e1f044931c0eb1846d7192becda /debian
parent7c0779da7c37f6ef6eff2f79dda6f1b0c57e3869 (diff)
parent1dd3c8f8ba49ec06e550d7376d27ff05ce024bec (diff)
downloadmariadb-git-36e59752e7fc70bc5179a3d730b5ce3ee58e4e30.tar.gz
Merge branch '10.2' into 10.3
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh16
-rw-r--r--debian/control6
-rw-r--r--debian/mariadb-plugin-tokudb.install1
-rw-r--r--debian/mariadb-server-10.2.triggers2
-rw-r--r--debian/mariadb-server-10.3.postinst19
5 files changed, 22 insertions, 22 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 132bb2eea7b..26cb9a926d0 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -36,19 +36,12 @@ fi
# Debian policy and targeting Debian Sid. Then case-by-case run in autobake-deb.sh
# tests for backwards compatibility and strip away parts on older builders.
-# If iproute2 is not available (before Debian Jessie and Ubuntu Trusty)
-# fall back to the old iproute package.
-if ! apt-cache madison iproute2 | grep 'iproute2 *|' >/dev/null 2>&1
-then
- sed 's/iproute2/iproute/' -i debian/control
-fi
-
# If libcrack2 (>= 2.9.0) is not available (before Debian Jessie and Ubuntu Trusty)
# clean away the cracklib stanzas so the package can build without them.
if ! apt-cache madison libcrack2-dev | grep 'libcrack2-dev *| *2\.9' >/dev/null 2>&1
then
sed '/libcrack2-dev/d' -i debian/control
- sed '/Package: mariadb-plugin-cracklib/,+11d' -i debian/control
+ sed '/Package: mariadb-plugin-cracklib/,+9d' -i debian/control
fi
# If libpcre3-dev (>= 2:8.35-3.2~) is not available (before Debian Jessie or Ubuntu Wily)
@@ -120,8 +113,7 @@ Breaks: mariadb-aws-key-management-10.1,
mariadb-aws-key-management-10.2
Replaces: mariadb-aws-key-management-10.1,
mariadb-aws-key-management-10.2
-Depends: libcurl3,
- mariadb-server-10.3,
+Depends: mariadb-server-10.3,
\${misc:Depends},
\${shlibs:Depends}
Description: Amazon Web Service Key Management Service Plugin for MariaDB
@@ -134,8 +126,8 @@ fi
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then
- sed -i -e "/Package: mariadb-plugin-tokudb/,+17d" debian/control
- sed -i -e "/Package: mariadb-plugin-mroonga/,+16d" debian/control
+ sed -i -e "/Package: mariadb-plugin-tokudb/,+19d" debian/control
+ sed -i -e "/Package: mariadb-plugin-mroonga/,+17d" debian/control
fi
# Adjust changelog, add new version
diff --git a/debian/control b/debian/control
index ba783955dc3..2465cfd6b27 100644
--- a/debian/control
+++ b/debian/control
@@ -423,7 +423,7 @@ Pre-Depends: adduser (>= 3.40),
mariadb-common (>= ${source:Version})
Depends: galera-3 (>=25.3),
gawk,
- iproute2,
+ iproute | iproute2,
libdbi-perl,
lsb-base (>= 3.0-10),
lsof,
@@ -569,6 +569,7 @@ Description: OQGraph storage engine for MariaDB
Package: mariadb-plugin-tokudb
Architecture: amd64
Depends: mariadb-server-10.3 (= ${binary:Version}),
+ libjemalloc1 (>= 3.0.0~),
${misc:Depends},
${shlibs:Depends}
Breaks: mariadb-server-10.0,
@@ -704,9 +705,6 @@ Depends: libcrack2 (>= 2.9.0),
Description: CrackLib Password Validation Plugin for MariaDB
This password validation plugin uses cracklib to allow only
sufficiently secure (as defined by cracklib) user passwords in MariaDB.
- .
- Plese refer to the MariaDB Knowledge Base on more information on
- how to use this tool.
Package: mariadb-test
Architecture: any
diff --git a/debian/mariadb-plugin-tokudb.install b/debian/mariadb-plugin-tokudb.install
index d15db03b3e5..5858b145b70 100644
--- a/debian/mariadb-plugin-tokudb.install
+++ b/debian/mariadb-plugin-tokudb.install
@@ -1,4 +1,5 @@
etc/mysql/conf.d/tokudb.cnf etc/mysql/mariadb.conf.d
+etc/systemd/system/mariadb.service.d/tokudb.conf
usr/bin/tokuft_logprint
usr/bin/tokuftdump
usr/lib/mysql/plugin/ha_tokudb.so
diff --git a/debian/mariadb-server-10.2.triggers b/debian/mariadb-server-10.2.triggers
new file mode 100644
index 00000000000..d1f5f5e14f1
--- /dev/null
+++ b/debian/mariadb-server-10.2.triggers
@@ -0,0 +1,2 @@
+interest-noawait /etc/mysql
+interest-noawait /etc/systemd/system/mariadb.service.d
diff --git a/debian/mariadb-server-10.3.postinst b/debian/mariadb-server-10.3.postinst
index aa6ea07a888..dbe664f30fb 100644
--- a/debian/mariadb-server-10.3.postinst
+++ b/debian/mariadb-server-10.3.postinst
@@ -50,14 +50,14 @@ EOF
return $retval
}
-# This is necessary because mysql_install_db removes the pid file in /var/run
-# and because changed configuration options should take effect immediately.
-# In case the server wasn't running at all it should be ok if the stop
-# script fails. I can't tell at this point because of the cleaned /var/run.
-set +e; invoke stop; set -e
-
case "$1" in
configure)
+ # This is needed because mysql_install_db removes the pid file in /var/run
+ # and because changed configuration options should take effect immediately.
+ # In case the server wasn't running at all it should be ok if the stop
+ # script fails. I can't tell at this point because of the cleaned /var/run.
+ set +e; invoke stop; set -e
+
mysql_statedir=/usr/share/mysql
mysql_datadir=/var/lib/mysql
mysql_logdir=/var/log/mysql
@@ -242,6 +242,13 @@ EOF
abort-upgrade|abort-remove|abort-configure)
;;
+ triggered)
+ if [ -x "$(command -v systemctl)" ]; then
+ systemctl daemon-reload
+ fi
+ invoke restart
+ ;;
+
*)
echo "postinst called with unknown argument '$1'" 1>&2
exit 1