summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-04-05 23:55:23 +0300
committerOtto Kekäläinen <otto@kekalainen.net>2020-05-17 15:46:34 +0300
commit8d056affd86dcfa0546b4eb2ce133812871b2bc3 (patch)
treefa8d8082924a318cc9d961b27deb8720f28ed204 /debian
parent9ddeccc299112864d98ced1b0415c086b7d98a6a (diff)
downloadmariadb-git-8d056affd86dcfa0546b4eb2ce133812871b2bc3.tar.gz
Travis-CI: Shorten deb build log to keep it under 4 MB
There is a 4 MB hard limit on Travis-CI and build output needs to be less than that. Silencing the 'make install' step gets rid of a lot of "Installing.." and "Missing.." and removing all mysql-test files will make the dh_missing warnings much shorter. Cherry-picked from 41952c85f1644690249ce624de7609cbebb93638.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 647c73e43e0..809911d4179 100755
--- a/debian/rules
+++ b/debian/rules
@@ -121,8 +121,13 @@ endif
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.2.mariadb.service
cp $(BUILDDIR)/support-files/mariadb@.service debian/mariadb-server-10.2.mariadb@.service
- # make install
- cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP)
+ # Run 'make install' without output since it is uninteresting and
+ # silencing it helps to make overall build log shorter and more readable
+ @echo "Running $(MAKE) install DESTDIR=$(TMP) ..."
+ cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP) > /dev/null
+
+ # If mariadb-test package is removed, also remove most of it's files
+ grep --quiet "Package: mariadb-test" debian/control || rm -rf $(TMP)/usr/share/mysql/mysql-test
# Delete runnable files we don't want to have in the test data package.
# This avoids triggering multiple Lintian errors.