summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2019-01-25 14:05:54 +0100
committerSergei Golubchik <serg@mariadb.org>2019-01-25 19:57:37 +0100
commitd4515d1305162b2b5a920412d01dd075d3e42f33 (patch)
tree7bb8bf5a8bfc54933950ea1a713d772540c06972 /debian
parent74f184aff253076781b7057ddba5e6460dfd467f (diff)
downloadmariadb-git-d4515d1305162b2b5a920412d01dd075d3e42f33.tar.gz
Deb: don't edit control file from inside rules file
It's too late. Might work or not (and on buster it doesn't).
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh5
-rwxr-xr-xdebian/rules5
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index b569df9118f..ac2f1395dcd 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -89,6 +89,11 @@ then
sed '/Package: mariadb-plugin-aws-key-management-10.2/,+12d' -i debian/control
fi
+# Don't build cassandra package if thrift is not installed
+if [[ ! -f /usr/local/include/thrift/Thrift.h && ! -f /usr/include/thrift/Thrift.h ]]
+then
+ sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
+fi
# Adjust changelog, add new version
echo "Incrementing changelog and starting build scripts"
diff --git a/debian/rules b/debian/rules
index e526e012172..3b1952ad2b9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -120,11 +120,6 @@ ifneq ($(ARCH), amd64)
sed -i -e "/Package: mariadb-plugin-tokudb/,+16d" debian/control
endif
- # If libthrift-dev was available (manually installed, as it is
- # not in Debian) and ha_cassandra.so was thus built, create package,
- # otherwise skip it.
- [ -f $(BUILDDIR)/storage/cassandra/ha_cassandra.so ] || sed -i -e "/Package: mariadb-plugin-cassandra/,+18d" debian/control
-
# Copy systemd files to a location available for dh_installinit
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.2.mariadb.service
cp $(BUILDDIR)/support-files/mariadb@.service debian/mariadb-server-10.2.mariadb@.service