summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2019-01-26 01:13:41 +0100
committerSergei Golubchik <serg@mariadb.org>2019-01-26 01:13:41 +0100
commit9b76e2843b5bdb57c35ec99c506711af0645684d (patch)
tree56bccb1bc8eb8aa441fd5683614c196e29b9c1ff /debian
parent06a37d37a192fe13bc8a7148ae74fd9d154e4be4 (diff)
parent3b1b665fcbe1b9ae7ee0d627105cfb69c9886179 (diff)
downloadmariadb-git-9b76e2843b5bdb57c35ec99c506711af0645684d.tar.gz
Merge branch '10.3' into 10.4
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh6
-rwxr-xr-xdebian/rules5
2 files changed, 6 insertions, 5 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 7b518742d54..3442afbf376 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -124,6 +124,12 @@ EOF
sed -i -e "/-DPLUGIN_AWS_KEY_MANAGEMENT=NO/d" debian/rules
fi
+# Don't build cassandra package if thrift is not installed
+if [[ ! -f /usr/local/include/thrift/Thrift.h && ! -f /usr/include/thrift/Thrift.h ]]
+then
+ sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
+fi
+
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then
diff --git a/debian/rules b/debian/rules
index 446b02b4164..13d1343671a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -114,11 +114,6 @@ override_dh_auto_install:
dh_testdir
dh_testroot
- # If libthrift-dev was available (manually installed, as it is
- # not in Debian) and ha_cassandra.so was thus built, create package,
- # otherwise skip it.
- [ -f $(BUILDDIR)/storage/cassandra/ha_cassandra.so ] || sed -i -e "/Package: mariadb-plugin-cassandra/,+20d" debian/control
-
ifneq (,$(filter linux,$(DEB_HOST_ARCH_OS)))
# Copy systemd files to a location available for dh_installinit
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.4.mariadb.service