summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2022-06-27 10:14:37 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2022-06-27 10:14:37 +0300
commit01d757036f5753fbbb54c6fef4bd7b312981ed88 (patch)
tree046889d0bec8d3202b7553584c7e9b5583c9e6b0 /debian
parentaf929146ed5d10f7cafe1091346e50a873eed3f1 (diff)
parentc86b1389de5fe44fbd659bb50d95017bc19324a5 (diff)
downloadmariadb-git-01d757036f5753fbbb54c6fef4bd7b312981ed88.tar.gz
Merge 10.3 into 10.4
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh16
-rw-r--r--debian/control3
2 files changed, 14 insertions, 5 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index c0026a1b2dd..1714c1a5868 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -17,8 +17,15 @@ export DEB_BUILD_OPTIONS="nocheck"
# Debian policy and targeting Debian Sid. Then case-by-case run in autobake-deb.sh
# tests for backwards compatibility and strip away parts on older builders.
-CODENAME="$(lsb_release -sc)"
-case "${CODENAME}" in
+LSBID="$(lsb_release -si | tr '[:upper:]' '[:lower:]')"
+LSBVERSION="$(lsb_release -sr | sed -e "s#\.##g")"
+LSBNAME="$(lsb_release -sc)"
+
+if [ -z "${LSBID}" ]
+then
+ LSBID="unknown"
+fi
+case "${LSBNAME}" in
stretch)
# MDEV-28022 libzstd-dev-1.1.3 minimum version
sed -i -e '/libzstd-dev/d' debian/control
@@ -55,10 +62,11 @@ UPSTREAM="${MYSQL_VERSION_MAJOR}.${MYSQL_VERSION_MINOR}.${MYSQL_VERSION_PATCH}${
PATCHLEVEL="+maria"
LOGSTRING="MariaDB build"
EPOCH="1:"
+VERSION="${EPOCH}${UPSTREAM}${PATCHLEVEL}~${LSBID:0:3}${LSBVERSION}"
-dch -b -D ${CODENAME} -v "${EPOCH}${UPSTREAM}${PATCHLEVEL}~${CODENAME}" "Automatic build with ${LOGSTRING}."
+dch -b -D ${LSBNAME} -v "${VERSION}" "Automatic build with ${LOGSTRING}."
-echo "Creating package version ${EPOCH}${UPSTREAM}${PATCHLEVEL}~${CODENAME} ... "
+echo "Creating package version ${VERSION} ... "
# Build the package
# Pass -I so that .git and other unnecessary temporary and source control files
diff --git a/debian/control b/debian/control
index e3938488fef..85d131bbd11 100644
--- a/debian/control
+++ b/debian/control
@@ -195,7 +195,8 @@ Depends: libmariadb-dev (= ${binary:Version}),
libmariadbd19 (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
-Breaks: libmysqld-dev
+Breaks: libmysqld-dev,
+ libmariadbd-dev (<= 10.2)
Replaces: libmysqld-dev
Description: MariaDB embedded database, development files
MariaDB is a fast, stable and true multi-user, multi-threaded SQL database