summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJames Clarke <jrtc27@debian.org>2018-05-29 09:23:23 +0300
committerOtto Kekäläinen <otto@mariadb.org>2018-05-29 23:52:47 +0300
commit26d50036d90302ef0deb9ceb97f1ada87484edb4 (patch)
tree1bd3ccb199ec2e5741c3805ed3ef1cf6a2a0fd50 /debian
parentdc0a76600b65950c478782203ac811e7e1027123 (diff)
downloadmariadb-git-26d50036d90302ef0deb9ceb97f1ada87484edb4.tar.gz
Deb: Fix FTBFS on non-Linux architectures that don't support systemd
For details see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=852728
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 9bcdda102ef..c92c6d1176f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,7 @@ BUILDDIR := builddir
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
DEBVERSION := $(shell dpkg-parsechangelog | awk '/^Version: / { print $$2 }' | sed 's/^.*-//' )
DEB_SOURCE_PACKAGE ?= $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
DEB_VERSION ?= $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
@@ -129,9 +130,11 @@ override_dh_auto_install:
# otherwise skip it.
[ -f $(BUILDDIR)/storage/cassandra/ha_cassandra.so ] || sed -i -e "/Package: mariadb-plugin-cassandra/,+20d" debian/control
+ifneq (,$(filter linux,$(DEB_BUILD_ARCH_OS)))
# Copy systemd files to a location available for dh_installinit
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.3.mariadb.service
cp $(BUILDDIR)/support-files/mariadb@.service debian/mariadb-server-10.3.mariadb@.service
+endif
# make install
cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP)