summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2018-07-03 10:22:43 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2018-07-03 10:22:43 +0300
commitc3289d27eef39a47fed2ce1ff239013ed6870f39 (patch)
tree2a6e2434287921eb6f5f7c7877e8da061803ed9e /debian
parent358ae4b46dd52b329154cff901b58e96fd223773 (diff)
parenteaab98f7022732b26b4ea590e1bb44308e253be8 (diff)
downloadmariadb-git-c3289d27eef39a47fed2ce1ff239013ed6870f39.tar.gz
Merge mariadb-10.3.8 into 10.3
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh33
-rw-r--r--debian/control6
-rw-r--r--debian/mariadb-plugin-tokudb.install1
-rw-r--r--debian/mariadb-server-10.3.postinst19
-rw-r--r--debian/mariadb-server-10.3.triggers2
5 files changed, 30 insertions, 31 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index ed584dc11d3..56575211c61 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -29,6 +29,12 @@ then
sed 's|-DDEB|-DPLUGIN_TOKUDB=NO -DPLUGIN_MROONGA=NO -DPLUGIN_ROCKSDB=NO -DPLUGIN_SPIDER=NO -DPLUGIN_OQGRAPH=NO -DPLUGIN_PERFSCHEMA=NO -DPLUGIN_SPHINX=NO -WITH_EMBEDDED_SERVER=OFF -DDEB|' -i debian/rules
fi
+# Convert gcc version to numberical value. Format is Mmmpp where M is Major
+# version, mm is minor version and p is patch.
+# -dumpfullversion & -dumpversion to make it uniform across old and new (>=7)
+GCCVERSION=$(gcc -dumpfullversion -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' \
+ -e 's/\.\([0-9]\)/0\1/g' \
+ -e 's/^[0-9]\{3,4\}$/&00/')
# Look up distro-version specific stuff
#
@@ -36,19 +42,12 @@ fi
# Debian policy and targeting Debian Sid. Then case-by-case run in autobake-deb.sh
# tests for backwards compatibility and strip away parts on older builders.
-# If iproute2 is not available (before Debian Jessie and Ubuntu Trusty)
-# fall back to the old iproute package.
-if ! apt-cache madison iproute2 | grep 'iproute2 *|' >/dev/null 2>&1
-then
- sed 's/iproute2/iproute/' -i debian/control
-fi
-
# If libcrack2 (>= 2.9.0) is not available (before Debian Jessie and Ubuntu Trusty)
# clean away the cracklib stanzas so the package can build without them.
if ! apt-cache madison libcrack2-dev | grep 'libcrack2-dev *| *2\.9' >/dev/null 2>&1
then
sed '/libcrack2-dev/d' -i debian/control
- sed '/Package: mariadb-plugin-cracklib/,+11d' -i debian/control
+ sed '/Package: mariadb-plugin-cracklib/,+9d' -i debian/control
fi
# If libpcre3-dev (>= 2:8.35-3.2~) is not available (before Debian Jessie or Ubuntu Wily)
@@ -85,19 +84,12 @@ fi
# Debian Jessie and older and on Ubuntu Xenial and older with the following error message:
# /usr/bin/ld.bfd.real: /tmp/ccOIwjFo.ltrans0.ltrans.o: relocation R_X86_64_PC32 against symbol
# `toku_product_name_strings' can not be used when making a shared object; recompile with -fPIC
-# Therefore we need to disable PIE on those releases using debhelper as proxy for detection.
-if ! apt-cache madison debhelper | grep 'debhelper *| *1[0-9]\.' >/dev/null 2>&1
+# Therefore we need to disable PIE on those releases using gcc as proxy for detection.
+if [[ $GCCVERSION -lt 60000 ]]
then
sed 's/hardening=+all$/hardening=+all,-pie/' -i debian/rules
fi
-
-# Convert gcc version to numberical value. Format is Mmmpp where M is Major
-# version, mm is minor version and p is patch.
-# -dumpfullversion & -dumpversion to make it uniform across old and new (>=7)
-GCCVERSION=$(gcc -dumpfullversion -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' \
- -e 's/\.\([0-9]\)/0\1/g' \
- -e 's/^[0-9]\{3,4\}$/&00/')
# Don't build rocksdb package if gcc version is less than 4.8 or we are running on
# x86 32 bit.
if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]] || [[ $TRAVIS ]]
@@ -120,8 +112,7 @@ Breaks: mariadb-aws-key-management-10.1,
mariadb-aws-key-management-10.2
Replaces: mariadb-aws-key-management-10.1,
mariadb-aws-key-management-10.2
-Depends: libcurl3,
- mariadb-server-10.3,
+Depends: mariadb-server-10.3,
\${misc:Depends},
\${shlibs:Depends}
Description: Amazon Web Service Key Management Service Plugin for MariaDB
@@ -136,8 +127,8 @@ fi
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then
- sed -i -e "/Package: mariadb-plugin-tokudb/,+17d" debian/control
- sed -i -e "/Package: mariadb-plugin-mroonga/,+16d" debian/control
+ sed -i -e "/Package: mariadb-plugin-tokudb/,+19d" debian/control
+ sed -i -e "/Package: mariadb-plugin-mroonga/,+17d" debian/control
sed -i -e "/Package: mariadb-plugin-spider/,+18d" debian/control
sed -i -e "/Package: mariadb-plugin-oqgraph/,+16d" debian/control
sed -i -e "/usr\/lib\/mysql\/plugin\/ha_sphinx.so/d" debian/mariadb-server-10.3.install
diff --git a/debian/control b/debian/control
index ba783955dc3..2465cfd6b27 100644
--- a/debian/control
+++ b/debian/control
@@ -423,7 +423,7 @@ Pre-Depends: adduser (>= 3.40),
mariadb-common (>= ${source:Version})
Depends: galera-3 (>=25.3),
gawk,
- iproute2,
+ iproute | iproute2,
libdbi-perl,
lsb-base (>= 3.0-10),
lsof,
@@ -569,6 +569,7 @@ Description: OQGraph storage engine for MariaDB
Package: mariadb-plugin-tokudb
Architecture: amd64
Depends: mariadb-server-10.3 (= ${binary:Version}),
+ libjemalloc1 (>= 3.0.0~),
${misc:Depends},
${shlibs:Depends}
Breaks: mariadb-server-10.0,
@@ -704,9 +705,6 @@ Depends: libcrack2 (>= 2.9.0),
Description: CrackLib Password Validation Plugin for MariaDB
This password validation plugin uses cracklib to allow only
sufficiently secure (as defined by cracklib) user passwords in MariaDB.
- .
- Plese refer to the MariaDB Knowledge Base on more information on
- how to use this tool.
Package: mariadb-test
Architecture: any
diff --git a/debian/mariadb-plugin-tokudb.install b/debian/mariadb-plugin-tokudb.install
index d15db03b3e5..5858b145b70 100644
--- a/debian/mariadb-plugin-tokudb.install
+++ b/debian/mariadb-plugin-tokudb.install
@@ -1,4 +1,5 @@
etc/mysql/conf.d/tokudb.cnf etc/mysql/mariadb.conf.d
+etc/systemd/system/mariadb.service.d/tokudb.conf
usr/bin/tokuft_logprint
usr/bin/tokuftdump
usr/lib/mysql/plugin/ha_tokudb.so
diff --git a/debian/mariadb-server-10.3.postinst b/debian/mariadb-server-10.3.postinst
index aa6ea07a888..dbe664f30fb 100644
--- a/debian/mariadb-server-10.3.postinst
+++ b/debian/mariadb-server-10.3.postinst
@@ -50,14 +50,14 @@ EOF
return $retval
}
-# This is necessary because mysql_install_db removes the pid file in /var/run
-# and because changed configuration options should take effect immediately.
-# In case the server wasn't running at all it should be ok if the stop
-# script fails. I can't tell at this point because of the cleaned /var/run.
-set +e; invoke stop; set -e
-
case "$1" in
configure)
+ # This is needed because mysql_install_db removes the pid file in /var/run
+ # and because changed configuration options should take effect immediately.
+ # In case the server wasn't running at all it should be ok if the stop
+ # script fails. I can't tell at this point because of the cleaned /var/run.
+ set +e; invoke stop; set -e
+
mysql_statedir=/usr/share/mysql
mysql_datadir=/var/lib/mysql
mysql_logdir=/var/log/mysql
@@ -242,6 +242,13 @@ EOF
abort-upgrade|abort-remove|abort-configure)
;;
+ triggered)
+ if [ -x "$(command -v systemctl)" ]; then
+ systemctl daemon-reload
+ fi
+ invoke restart
+ ;;
+
*)
echo "postinst called with unknown argument '$1'" 1>&2
exit 1
diff --git a/debian/mariadb-server-10.3.triggers b/debian/mariadb-server-10.3.triggers
new file mode 100644
index 00000000000..d1f5f5e14f1
--- /dev/null
+++ b/debian/mariadb-server-10.3.triggers
@@ -0,0 +1,2 @@
+interest-noawait /etc/mysql
+interest-noawait /etc/systemd/system/mariadb.service.d