summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-03-16 13:07:52 +0200
committerOtto Kekäläinen <otto@kekalainen.net>2020-04-05 23:55:45 +0300
commit811e4409ce587bc4b693cc0262bccccacc0238fb (patch)
tree52cdecdadd299e4b6a6f40cb2cd16c34b49bced7 /debian
parent396e83d777020611bac55a636e3c7e42e4883b34 (diff)
downloadmariadb-git-811e4409ce587bc4b693cc0262bccccacc0238fb.tar.gz
Travis-CI: Shorten deb build log to keep it under 4 MB
There is a 4 MB hard limit on Travis-CI and build output needs to be less than that. Silencing the 'make install' step gets rid of a lot of "Installing.." and "Missing.." and removing all mysql-test files will make the dh_missing warnings much shorter.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index e8ca0d92527..6c46c2f4670 100755
--- a/debian/rules
+++ b/debian/rules
@@ -117,8 +117,13 @@ ifneq (,$(filter linux,$(DEB_HOST_ARCH_OS)))
cp $(BUILDDIR)/support-files/mariadb@.service debian/mariadb-server-10.3.mariadb@.service
endif
- # make install
- cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP)
+ # Run 'make install' without output since it is uninteresting and
+ # silencing it helps to make overall build log shorter and more readable
+ @echo "Running $(MAKE) install DESTDIR=$(TMP) ..."
+ cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP) > /dev/null
+
+ # If mariadb-test package is removed, also remove most of it's files
+ grep --quiet "Package: mariadb-test" debian/control || rm -rf $(TMP)/usr/share/mysql/mysql-test
# Delete runnable files we don't want to have in the test data package.
# This avoids triggering multiple Lintian errors.