summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@mariadb.org>2018-01-12 13:06:14 +0000
committerVicențiu-Marian Ciorbaru <cvicentiu@gmail.com>2018-01-16 13:48:00 +0200
commit711e8c56346d0f9a4717ea2b2e0c7a98b6c247a9 (patch)
treefba3114f0c7e4dacee3354951ed4aed9f6e59f09 /debian
parenta41192def8ab67f4420e437ebd26646023a9bcca (diff)
downloadmariadb-git-711e8c56346d0f9a4717ea2b2e0c7a98b6c247a9.tar.gz
MDEV-12642: Build deb source packages on buildbot, just not on Travis-CI
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh14
1 files changed, 11 insertions, 3 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 5948229ac28..fca3482e64b 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -111,12 +111,20 @@ dch -b -D ${CODENAME} -v "${UPSTREAM}${PATCHLEVEL}~${CODENAME}" "Automatic build
echo "Creating package version ${UPSTREAM}${PATCHLEVEL}~${CODENAME} ... "
+# On Travis CI, use -b to build binary only packages as there is no need to
+# waste time on generating the source package.
+if [[ $TRAVIS ]]
+then
+ BUILDPACKAGE_FLAGS="-b"
+fi
+
# Build the package
# Pass -I so that .git and other unnecessary temporary and source control files
# will be ignored by dpkg-source when creating the tar.gz source package.
-# Use -b to build binary only packages as there is no need to waste time on
-# generating the source package.
-fakeroot dpkg-buildpackage -us -uc -I -b
+fakeroot dpkg-buildpackage -us -uc -I $BUILDPACKAGE_FLAGS
+
+# If the step above fails due to missing dependencies, you can manually run
+# sudo mk-build-deps debian/control -r -i
# Don't log package contents on Travis-CI to save time and log size
if [[ ! $TRAVIS ]]