summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-04-13 09:33:02 +0300
committerVicențiu-Marian Ciorbaru <vicentiu@mariadb.org>2020-04-23 10:07:07 +0300
commitda64ec1ede5a4c795cedfe0b7010a07637b68f44 (patch)
tree33efc2baa8fdc6337488545ca06f57ea99fbc139 /debian
parent9cc1c74ca3391779d5f00ece09981d2932cf173b (diff)
downloadmariadb-git-da64ec1ede5a4c795cedfe0b7010a07637b68f44.tar.gz
MDEV-19110: Remove Cassandra from Debian packaging
Cassandra has deprecated their Thrift interface years ago (a few months after Cassandra SE was released). The new way to access Cassandra is to use the CQL Connector, which does not use Thrift. There have been talks to make a CassandraSE V2 but no usable code have been produced. The motivation to keep CassandraSE in the MariaDB source code is to have it as an example for such future attempts. It can stay in the source code but it should be removed from packaging to avoid Debian packaging maintenance work around trying to compile it and have tests pass on new platform. If somebody wants Cassandra, they can use the 10.4 branch.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh8
-rw-r--r--debian/control23
-rw-r--r--debian/mariadb-plugin-cassandra.install2
-rwxr-xr-xdebian/rules1
4 files changed, 2 insertions, 32 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 3383ed73fa8..354a2706e1e 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -80,12 +80,6 @@ fi
# Always remove AWS plugin, see -DNOT_FOR_DISTRIBUTION in CMakeLists.txt
sed '/Package: mariadb-plugin-aws-key-management-10.2/,/^$/d' -i debian/control
-# Don't build Cassandra package if Thrift is not installed
-if [[ ! -f /usr/local/include/thrift/Thrift.h && ! -f /usr/include/thrift/Thrift.h ]]
-then
- sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
-fi
-
# If libpcre2-dev is not available (before Debian Stretch and Ubuntu Xenial)
# attempt to build using older libpcre3-dev (SIC!)
if ! apt-cache madison libpcre2-dev | grep --quiet 'libpcre2-dev'
@@ -93,7 +87,7 @@ then
sed 's/libcurl4-openssl-dev | libcurl4-dev/libpcre3-dev/' -i debian/control
fi
-# Cassandra, Mroonga etc never built on Travis CI anyway, see build flags above
+# Mroonga, Spider etc never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then
sed -i -e "/Package: mariadb-plugin-mroonga/,/^$/d" debian/control
diff --git a/debian/control b/debian/control
index c40c02a7495..5bd50e818da 100644
--- a/debian/control
+++ b/debian/control
@@ -718,29 +718,6 @@ Description: Spider storage engine for MariaDB
instances to be handled as if they were on the same instance. It refers to one
possible implementation of ISO/IEC 9075-9:2008 SQL/MED.
-Package: mariadb-plugin-cassandra
-Architecture: any
-Depends: mariadb-server-10.5 (= ${binary:Version}),
- ${misc:Depends},
- ${shlibs:Depends}
-Breaks: mariadb-server-10.0,
- mariadb-server-10.1,
- mariadb-server-10.2,
- mariadb-server-10.3,
- mariadb-server-10.4
-Replaces: mariadb-server-10.0,
- mariadb-server-10.1,
- mariadb-server-10.2,
- mariadb-server-10.3,
- mariadb-server-10.4
-Description: Cassandra storage engine for MariaDB
- The Cassandra Storage Engine allows access to data in a Cassandra cluster from
- MariaDB, combining the best of SQL and no-SQL worlds. Cassandra SE (storage
- engine) makes Cassandra's column family appear as a table in MariaDB that you
- can insert to, update, and select from. You can write joins against this table,
- it is possible to join data that's stored in MariaDB with data that's stored in
- Cassandra.
-
Package: mariadb-plugin-gssapi-server
Architecture: any
Depends: libgssapi-krb5-2,
diff --git a/debian/mariadb-plugin-cassandra.install b/debian/mariadb-plugin-cassandra.install
deleted file mode 100644
index ca195058a17..00000000000
--- a/debian/mariadb-plugin-cassandra.install
+++ /dev/null
@@ -1,2 +0,0 @@
-etc/mysql/conf.d/cassandra.cnf etc/mysql/mariadb.conf.d
-usr/lib/mysql/plugin/ha_cassandra.so
diff --git a/debian/rules b/debian/rules
index 3f8543a3bda..4c3d855d1c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -86,6 +86,7 @@ endif
-DCMAKE_SYSTEM_PROCESSOR=$(DEB_HOST_ARCH) \
-DBUILD_CONFIG=mysql_release \
-DWITHOUT_TOKUDB=true \
+ -DWITHOUT_CASSANDRA=true \
-DPLUGIN_AWS_KEY_MANAGEMENT=NO \
-DDEB=$(DEB_VENDOR) ..'