summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-03-16 10:39:43 +0200
committerOtto Kekäläinen <otto@kekalainen.net>2020-04-04 20:42:00 +0300
commit80abfa0edafb31617fe46d9908963615e0c1b40f (patch)
tree12dc7780e13b8bcb03fcb942c8198ff068e08a02 /debian
parent1589cf1cb3048984240f025ddc0c82fb311827fc (diff)
downloadmariadb-git-80abfa0edafb31617fe46d9908963615e0c1b40f.tar.gz
Don't force to use all processors in autobake-deb.sh
The dpkg-buildpackage has by default sensible values for --jobs and --try-jobs, and it also inherits whatever 'parallel' is set in DEB_BUILD_OPTIONS. Overriding it here should not be needed and removing it is better, since it allows build systems to control the level or parallel builds via DEB_BUILD_OPTIONS if they want, which they often do (e.g. to avoid CPU congestion or overheating laptops).
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 90a3f6112e0..90fdd12de20 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -126,7 +126,7 @@ fi
# Build the package
# Pass -I so that .git and other unnecessary temporary and source control files
# will be ignored by dpkg-source when creating the tar.gz source package.
-fakeroot dpkg-buildpackage -us -uc -I $BUILDPACKAGE_FLAGS -j$(nproc)
+fakeroot dpkg-buildpackage -us -uc -I $BUILDPACKAGE_FLAGS
# If the step above fails due to missing dependencies, you can manually run
# sudo mk-build-deps debian/control -r -i