summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-03-16 13:07:52 +0200
committerOtto Kekäläinen <otto@kekalainen.net>2020-04-06 09:07:02 +0300
commitb6eabce13941cde954d451f7be07c1e7ffd3bdcc (patch)
treeb809d7f5437203c751ed0f5167504ea491ed0fab /debian
parent28604c349bbb2ed73c93e56eb5ac3bf0d7269f52 (diff)
downloadmariadb-git-b6eabce13941cde954d451f7be07c1e7ffd3bdcc.tar.gz
Travis-CI: Shorten deb build log to keep it under 4 MB
There is a 4 MB hard limit on Travis-CI and build output needs to be less than that. Silencing the 'make install' step gets rid of a lot of "Installing.." and "Missing.." and removing all mysql-test files will make the dh_missing warnings much shorter.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 360d22d3836..c7862141c71 100755
--- a/debian/rules
+++ b/debian/rules
@@ -117,8 +117,13 @@ ifneq (,$(filter linux,$(DEB_HOST_ARCH_OS)))
cp $(BUILDDIR)/support-files/mariadb@.service debian/mariadb-server-10.4.mariadb@.service
endif
- # make install
- cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP)
+ # Run 'make install' without output since it is uninteresting and
+ # silencing it helps to make overall build log shorter and more readable
+ @echo "Running $(MAKE) install DESTDIR=$(TMP) ..."
+ cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP) > /dev/null
+
+ # If mariadb-test package is removed, also remove most of it's files
+ grep --quiet "Package: mariadb-test" debian/control || rm -rf $(TMP)/usr/share/mysql/mysql-test
# Delete runnable files we don't want to have in the test data package.
# This avoids triggering multiple Lintian errors.