summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-12-21 10:43:16 +0200
committerOtto Kekäläinen <otto@kekalainen.net>2020-12-21 19:03:29 +0200
commitd18090979662c9f1f5d005859587a508b47069d9 (patch)
tree62edcbfc3988d6e33973d76639accdb8b7775fa7 /debian
parente7c7f5c1bbac9a081775a1dc50088ae1e32e2a8d (diff)
downloadmariadb-git-d18090979662c9f1f5d005859587a508b47069d9.tar.gz
Deb: Don't build ColumnStore in native builds, only in autobake-deb.sh
ColumnStore files and debian/control stanza was removed in 1edd2243, and thus will not be included in a native build. Also adapt the debian/rules to follow this same policy and only build ColumnStore in builds triggered from autobake-deb.sh. Avoiding building ColumnStore in vain saves a lot of build time and disk space.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh3
-rwxr-xr-xdebian/rules3
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index d96e92a2177..22d910920bd 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -22,6 +22,9 @@ if [[ -d storage/columnstore/columnstore/debian ]]; then
cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
echo >> debian/control
cat storage/columnstore/columnstore/debian/control >> debian/control
+ # Don't build ColumnStore as part of the native build, only build it when triggered
+ # by autobake-deb.sh
+ sed 's|-DPLUGIN_COLUMNSTORE=NO|-DPLUGIN_COLUMNSTORE=YES|' -i debian/rules
fi
# General CI optimizations to keep build output smaller
diff --git a/debian/rules b/debian/rules
index e4c9963efb3..09d2a78d7ce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -85,6 +85,8 @@ ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
dh_auto_build --builddirectory=builddir-native -- import_executables
endif
+ # Don't build ColumnStore as part of the native build, only build it when triggered
+ # by autobake-deb.sh. Saves build time and disk space.
mkdir -p $(BUILDDIR) && cd $(BUILDDIR) && \
sh -c 'PATH=$${MYSQL_BUILD_PATH:-"/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin"} \
CC=${CC} \
@@ -99,6 +101,7 @@ endif
-DPLUGIN_TOKUDB=NO \
-DPLUGIN_CASSANDRA=NO \
-DPLUGIN_AWS_KEY_MANAGEMENT=NO \
+ -DPLUGIN_COLUMNSTORE=NO \
-DDEB=$(DEB_VENDOR) ..'
# This is needed, otherwise 'make test' will run before binaries have been built