summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-08-23 11:28:08 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2021-08-23 11:28:08 +0300
commit64f7dffcc7e0e69c31d9a36c2090a26300e57c4c (patch)
tree698b7b23aaf9ed0fd9794e1d0f20dba309ddb316 /debian
parent3bf42eb21bb8744b12b2b5ddb4f87425e328c36f (diff)
parent49f95c40656a7333586e3ee11ff981ff41aebd40 (diff)
downloadmariadb-git-64f7dffcc7e0e69c31d9a36c2090a26300e57c4c.tar.gz
Merge 10.6 into 10.7
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh9
-rw-r--r--debian/mariadb-server-10.7.postinst9
-rwxr-xr-xdebian/rules9
3 files changed, 9 insertions, 18 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index d6d0c41dea2..4268714e979 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -24,10 +24,13 @@ then
# build less verbose
# MCOL-4149: ColumnStore builds are so slow and big that they must be skipped on
# both Travis-CI and Gitlab-CI
- sed -e '/Add support for verbose builds/,/^$/d' \
- -e '/ColumnStore is part of the build/,/^$/d' \
- -e 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' \
+ sed -e 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' \
-i debian/rules
+elif [ -d storage/columnstore/columnstore/debian ]
+then
+ cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
+ echo >> debian/control
+ cat storage/columnstore/columnstore/debian/control >> debian/control
fi
# Don't build or try to put files in a package for selected plugins and components on Travis-CI
diff --git a/debian/mariadb-server-10.7.postinst b/debian/mariadb-server-10.7.postinst
index 97828ed15e8..23fa348693b 100644
--- a/debian/mariadb-server-10.7.postinst
+++ b/debian/mariadb-server-10.7.postinst
@@ -124,7 +124,7 @@ EOF
if [ ! -d "$mysql_datadir" ] && [ ! -L "$mysql_datadir" ]; then mkdir -Z "$mysql_datadir" ; fi
if [ ! -d "$mysql_logdir" ] && [ ! -L "$mysql_logdir" ]; then mkdir -Z "$mysql_logdir" ; fi
# When creating an ext3 jounal on an already mounted filesystem like e.g.
- # /var/lib/mysql, you get a .journal file that is not modifyable by chown.
+ # /var/lib/mysql, you get a .journal file that is not modifiable by chown.
# The mysql_statedir must not be writable by the mysql user under any
# circumstances as it contains scripts that are executed by root.
set +e
@@ -161,7 +161,7 @@ EOF
# Clean up old flags before setting new one
rm -f $mysql_datadir/debian-*.flag
# Flag data dir to avoid downgrades
- touch "$mysql_datadir/debian-$MAJOR_VER.flag"
+ touch $mysql_datadir/debian-10.7.flag
# initiate databases. Output is not allowed by debconf :-(
# This will fail if we are upgrading an existing database; in this case
@@ -175,9 +175,6 @@ EOF
$ERR_LOGGER
set -e
- # To avoid downgrades.
- touch "$mysql_statedir/debian-$MAJOR_VER.flag"
-
# On new installations root user can connect via unix_socket.
# But on upgrades, scripts rely on debian-sys-maint user and
# credentials in /etc/mysql/debian.cnf
@@ -251,7 +248,7 @@ EOF
;;
esac
-db_stop # in case invoke failes
+db_stop # in case invoke fails
# dh_systemd_start doesn't emit anything since we still ship /etc/init.d/mariadb.
# Thus MariaDB server is started via init.d script, which in turn redirects to
diff --git a/debian/rules b/debian/rules
index 64f497c4342..a1075ffb9ac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -73,15 +73,6 @@ ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
dh_auto_build --builddirectory=builddir-native -- import_executables
endif
- # ColumnStore is part of the build
-ifneq (32,$(DEB_HOST_ARCH_BITS))
- # Take the files and part of control from MCS directory
- cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
- # Don't include twice
- grep -q '^Package: mariadb-plugin-columnstore$$' debian/control || \
- ( echo && cat storage/columnstore/columnstore/debian/control ) >> debian/control
-endif
-
echo "server:Version=$(DEB_VERSION)" >> debian/substvars
# RocksDB and Column Store cannot build on 32-bit platforms