summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorVicențiu Ciorbaru <vicentiu@mariadb.org>2017-04-01 10:12:28 +0300
committerVicențiu Ciorbaru <vicentiu@mariadb.org>2017-04-01 10:17:26 +0300
commit321f5d9d70153a020a3f8442ee84abed248307bb (patch)
tree5822e8be4002b05882f6f1652d1eeb1c92a4e059 /debian
parent788382f77a3253ef0152330dfecadec0afcab841 (diff)
downloadmariadb-git-321f5d9d70153a020a3f8442ee84abed248307bb.tar.gz
Fix debian architecture parsing
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index bdb5535da99..b6d1711e6ea 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -77,7 +77,7 @@ fi
GCCVERSION=$(gcc -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' -e 's/\.\([0-9]\)/0\1/g' -e 's/^[0-9]\{3,4\}$/&00/')
# Don't build rocksdb package if gcc version is less than 4.8 or we are running on
# x86 32 bit.
-if [ $GCCVERSION -lt 40800 ] || [ $(uname -i) -eq "i386" ] || [$(uname -i) -eq "i486"]
+if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]]
then
sed '/Package: mariadb-plugin-rocksdb/,+7d' -i debian/control
fi