summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2019-01-25 20:33:47 +0100
committerSergei Golubchik <serg@mariadb.org>2019-01-25 20:35:40 +0100
commit3b1b665fcbe1b9ae7ee0d627105cfb69c9886179 (patch)
tree94479c6cb014effd97d7c95a20c0338651f363b1 /debian
parenta4ab66c8f86d79a1b6bf8aadbe0282e2c71c55a8 (diff)
parent3fb6d2587d6498c50c82aac77062d95ad5f2237a (diff)
downloadmariadb-git-3b1b665fcbe1b9ae7ee0d627105cfb69c9886179.tar.gz
Merge branch '10.2' into 10.3
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh6
-rwxr-xr-xdebian/rules5
2 files changed, 6 insertions, 5 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 6f859aa01ef..93d2b695397 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -124,6 +124,12 @@ EOF
sed -i -e "/-DPLUGIN_AWS_KEY_MANAGEMENT=NO/d" debian/rules
fi
+# Don't build cassandra package if thrift is not installed
+if [[ ! -f /usr/local/include/thrift/Thrift.h && ! -f /usr/include/thrift/Thrift.h ]]
+then
+ sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
+fi
+
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then
diff --git a/debian/rules b/debian/rules
index c3252fb585e..93bfe01e55e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -114,11 +114,6 @@ override_dh_auto_install:
dh_testdir
dh_testroot
- # If libthrift-dev was available (manually installed, as it is
- # not in Debian) and ha_cassandra.so was thus built, create package,
- # otherwise skip it.
- [ -f $(BUILDDIR)/storage/cassandra/ha_cassandra.so ] || sed -i -e "/Package: mariadb-plugin-cassandra/,+20d" debian/control
-
ifneq (,$(filter linux,$(DEB_HOST_ARCH_OS)))
# Copy systemd files to a location available for dh_installinit
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.3.mariadb.service