summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTeodor Mircea Ionita <teodor@mariadb.org>2018-11-22 16:26:03 +0200
committerSergei Golubchik <vuvova@gmail.com>2018-12-21 13:44:14 +0100
commit779151db80d5512c922227eeb32cb0164f9f01fa (patch)
tree4a6a86a27006a54ac8e3bacf99919f81ffec640e /debian
parent2999492c3278528ceb9f37bd6cfca5ca5295ef9a (diff)
downloadmariadb-git-779151db80d5512c922227eeb32cb0164f9f01fa.tar.gz
autobake-deb: fixes for AWS SDK build eligibility checks.
Add check for git command and test for internet connectivity using bash /dev/tcp interface, instead of wget and curl which might not be available, thus reducing dependencies for this script.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 4e66f13615f..a08f1a404b7 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -102,7 +102,7 @@ fi
# AWS SDK also requires the build machine to have network access and git, so
# it cannot be part of the base version included in Linux distros, but a pure
# custom built plugin.
-if [[ $GCCVERSION -gt 40800 ]] && [[ ! $TRAVIS ]] && wget --timeout 15 --tries 1 --quiet --output-document /dev/null https://github.com/
+if [[ $GCCVERSION -gt 40800 ]] && [[ ! $TRAVIS ]] && [[ -x "$(command -v git)" ]] && $(timeout 3s bash -c 'cat </dev/tcp/github.com/22')
then
cat <<EOF >> debian/control