summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniel Black <daniel@mariadb.org>2022-03-16 13:25:56 +1100
committerDaniel Black <daniel@mariadb.org>2022-03-16 16:39:10 +1100
commit069139a549a62f26d566c1aea2a49c13e9e8a654 (patch)
treedae7c9ae7a4929ed7a897eda2c6c316fd2394e4e /debian
parent9c6135e81f29b3e3286d6b864c0fdafc2fea16ce (diff)
parent6a2d88c132221ea07dd322060089c85ff5e469b5 (diff)
downloadmariadb-git-069139a549a62f26d566c1aea2a49c13e9e8a654.tar.gz
Merge 10.3 to 10.4
extra2_read_len resolved by keeping the implementation in sql/table.cc by exposed it for use by ha_partition.cc Remove identical implementation in unireg.h (ref: bfed2c7d57a7ca34936d6ef0688af7357592dc40)
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh125
-rw-r--r--debian/control5
2 files changed, 16 insertions, 114 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 9452ef4f458..c0026a1b2dd 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -6,35 +6,10 @@
# Exit immediately on any error
set -e
-# This file is invocated from Buildbot and Travis-CI to build deb packages.
-# As both of those CI systems have many parallel jobs that include different
-# parts of the test suite, we don't need to run the mysql-test-run at all when
-# building the deb packages here.
-export DEB_BUILD_OPTIONS="nocheck $DEB_BUILD_OPTIONS"
-
-# Travis-CI optimizations
-if [[ $TRAVIS ]]
-then
- # On Travis-CI, the log must stay under 4MB so make the build less verbose
- sed -i -e '/Add support for verbose builds/,/^$/d' debian/rules
-
- # Don't include test suite package on Travis-CI to make the build time shorter
- sed '/Package: mariadb-test-data/,/^$/d' -i debian/control
- sed '/Package: mariadb-test$/,/^$/d' -i debian/control
-
- # Don't build the test package at all to save time and disk space
- sed 's|DINSTALL_MYSQLTESTDIR=share/mysql/mysql-test|DINSTALL_MYSQLTESTDIR=false|' -i debian/rules
-
- # Also skip building RocksDB and TokuDB to save even more time and disk space
- sed 's|-DDEB|-DPLUGIN_TOKUDB=NO -DPLUGIN_MROONGA=NO -DPLUGIN_ROCKSDB=NO -DPLUGIN_SPIDER=NO -DPLUGIN_OQGRAPH=NO -DPLUGIN_PERFSCHEMA=NO -DPLUGIN_SPHINX=NO -WITH_EMBEDDED_SERVER=OFF -DDEB|' -i debian/rules
-fi
-
-# Convert gcc version to numberical value. Format is Mmmpp where M is Major
-# version, mm is minor version and p is patch.
-# -dumpfullversion & -dumpversion to make it uniform across old and new (>=7)
-GCCVERSION=$(gcc -dumpfullversion -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' \
- -e 's/\.\([0-9]\)/0\1/g' \
- -e 's/^[0-9]\{3,4\}$/&00/')
+# On Buildbot, don't run the mysql-test-run test suite as part of build.
+# It takes a lot of time, and we will do a better test anyway in
+# Buildbot, running the test suite from installed .debs on a clean VM.
+export DEB_BUILD_OPTIONS="nocheck"
# Look up distro-version specific stuff
#
@@ -50,49 +25,8 @@ case "${CODENAME}" in
;;
esac
-# If libcrack2 (>= 2.9.0) is not available (before Debian Jessie and Ubuntu Trusty)
-# clean away the cracklib stanzas so the package can build without them.
-if ! apt-cache madison libcrack2-dev | grep 'libcrack2-dev *| *2\.9' >/dev/null 2>&1
-then
- sed '/libcrack2-dev/d' -i debian/control
- sed '/Package: mariadb-plugin-cracklib/,/^$/d' -i debian/control
-fi
-
-# If libpcre3-dev (>= 2:8.35-3.2~) is not available (before Debian Jessie or Ubuntu Wily)
-# clean away the PCRE3 stanzas so the package can build without them.
-# Update check when version 2:8.40 or newer is available.
-if ! apt-cache madison libpcre3-dev | grep 'libpcre3-dev *| *2:8\.3[2-9]' >/dev/null 2>&1
-then
- sed '/libpcre3-dev/d' -i debian/control
-fi
-
-# If libsystemd-dev is not available (before Debian Jessie or Ubuntu Wily)
-# clean away the systemd stanzas so the package can build without them.
-if ! apt-cache madison libsystemd-dev | grep 'libsystemd-dev' >/dev/null 2>&1
-then
- sed '/dh-systemd/d' -i debian/control
- sed '/libsystemd-dev/d' -i debian/control
- sed 's/ --with systemd//' -i debian/rules
- sed '/systemd/d' -i debian/rules
- sed '/\.service/d' -i debian/rules
- sed '/galera_new_cluster/d' -i debian/mariadb-server-10.4.install
- sed '/galera_recovery/d' -i debian/mariadb-server-10.4.install
- sed '/mariadb-service-convert/d' -i debian/mariadb-server-10.4.install
-fi
-
-# The binaries should be fully hardened by default. However TokuDB compilation seems to fail on
-# Debian Jessie and older and on Ubuntu Xenial and older with the following error message:
-# /usr/bin/ld.bfd.real: /tmp/ccOIwjFo.ltrans0.ltrans.o: relocation R_X86_64_PC32 against symbol
-# `toku_product_name_strings' can not be used when making a shared object; recompile with -fPIC
-# Therefore we need to disable PIE on those releases using gcc as proxy for detection.
-if [[ $GCCVERSION -lt 60000 ]]
-then
- sed 's/hardening=+all$/hardening=+all,-pie/' -i debian/rules
-fi
-
-# Don't build rocksdb package if gcc version is less than 4.8 or we are running on
-# x86 32 bit.
-if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]] || [[ $TRAVIS ]]
+# Don't build rocksdb package on x86 32 bit.
+if [[ $(arch) =~ i[346]86 ]]
then
sed '/Package: mariadb-plugin-rocksdb/,/^$/d' -i debian/control
fi
@@ -112,26 +46,6 @@ then
sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
fi
-# From Debian Stretch/Ubuntu Bionic onwards dh-systemd is just an empty
-# transitional metapackage and the functionality was merged into debhelper.
-# In Ubuntu Hirsute is was completely removed, so it can't be referenced anymore.
-# Keep using it only on Debian Jessie and Ubuntu Xenial.
-if apt-cache madison dh-systemd | grep 'dh-systemd' >/dev/null 2>&1
-then
- sed 's/debhelper (>= 9.20160709~),/debhelper (>= 9), dh-systemd,/' -i debian/control
-fi
-
-# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
-if [[ $TRAVIS ]]
-then
- sed -i -e "/Package: mariadb-plugin-tokudb/,/^$/d" debian/control
- sed -i -e "/Package: mariadb-plugin-mroonga/,/^$/d" debian/control
- sed -i -e "/Package: mariadb-plugin-spider/,/^$/d" debian/control
- sed -i -e "/Package: mariadb-plugin-oqgraph/,/^$/d" debian/control
- sed -i -e "/usr\/lib\/mysql\/plugin\/ha_sphinx.so/d" debian/mariadb-server-10.4.install
- sed -i -e "/Package: libmariadbd-dev/,/^$/d" debian/control
-fi
-
# Adjust changelog, add new version
echo "Incrementing changelog and starting build scripts"
@@ -146,13 +60,6 @@ dch -b -D ${CODENAME} -v "${EPOCH}${UPSTREAM}${PATCHLEVEL}~${CODENAME}" "Automat
echo "Creating package version ${EPOCH}${UPSTREAM}${PATCHLEVEL}~${CODENAME} ... "
-# On Travis CI, use -b to build binary only packages as there is no need to
-# waste time on generating the source package.
-if [[ $TRAVIS ]]
-then
- BUILDPACKAGE_FLAGS="-b"
-fi
-
# Build the package
# Pass -I so that .git and other unnecessary temporary and source control files
# will be ignored by dpkg-source when creating the tar.gz source package.
@@ -161,17 +68,13 @@ fakeroot dpkg-buildpackage -us -uc -I $BUILDPACKAGE_FLAGS -j$(nproc)
# If the step above fails due to missing dependencies, you can manually run
# sudo mk-build-deps debian/control -r -i
-# Don't log package contents on Travis-CI to save time and log size
-if [[ ! $TRAVIS ]]
-then
- echo "List package contents ..."
- cd ..
- for package in `ls *.deb`
- do
- echo $package | cut -d '_' -f 1
- dpkg-deb -c $package | awk '{print $1 " " $2 " " $6}' | sort -k 3
- echo "------------------------------------------------"
- done
-fi
+echo "List package contents ..."
+cd ..
+for package in `ls *.deb`
+do
+ echo $package | cut -d '_' -f 1
+ dpkg-deb -c $package | awk '{print $1 " " $2 " " $6}' | sort -k 3
+ echo "------------------------------------------------"
+done
echo "Build complete"
diff --git a/debian/control b/debian/control
index d995bf2ba8d..e3938488fef 100644
--- a/debian/control
+++ b/debian/control
@@ -5,10 +5,9 @@ Maintainer: MariaDB Developers <maria-developers@lists.launchpad.net>
Build-Depends: bison,
chrpath,
cmake (>= 2.7),
- debhelper (>= 9.20160709~),
+ debhelper (>= 10),
dh-apparmor,
dh-exec,
- dh-systemd,
gdb,
libaio-dev [linux-any],
libboost-dev,
@@ -436,7 +435,7 @@ Pre-Depends: adduser (>= 3.40),
mariadb-common (>= ${source:Version})
Depends: galera-4 (>=26.4),
gawk,
- iproute | iproute2,
+ iproute2,
libdbi-perl,
lsb-base (>= 3.0-10),
lsof,