summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2019-02-20 12:47:14 +0100
committerSergei Golubchik <serg@mariadb.org>2019-03-01 12:40:43 -0500
commit000c6cfc610bc3a0d205e81ca20726122314fb35 (patch)
treebcd33bf73a598536852586ac4c9f062a8f235b89 /debian
parent4a1c66290dc81244f0f68c24666382fb2dae8f86 (diff)
downloadmariadb-git-000c6cfc610bc3a0d205e81ca20726122314fb35.tar.gz
debian: more robust control file hacking
when deleting a package, delete up to the next empty line, instead of relying on a package description being of some fixed number of lines long
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index ac2f1395dcd..f53439340a4 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -24,8 +24,8 @@ then
sed -i -e '/Add support for verbose builds/,+2d' debian/rules
# Don't include test suite package on Travis-CI to make the build time shorter
- sed '/Package: mariadb-test-data/,+26d' -i debian/control
- sed '/Package: mariadb-test/,+34d' -i debian/control
+ sed '/Package: mariadb-test-data/,/^$/d' -i debian/control
+ sed '/Package: mariadb-test/,/^$/d' -i debian/control
fi
@@ -47,7 +47,7 @@ fi
if ! apt-cache madison libcrack2-dev | grep 'libcrack2-dev *| *2\.9' >/dev/null 2>&1
then
sed '/libcrack2-dev/d' -i debian/control
- sed '/Package: mariadb-plugin-cracklib/,+9d' -i debian/control
+ sed '/Package: mariadb-plugin-cracklib/,/^$/d' -i debian/control
fi
# If libpcre3-dev (>= 2:8.35-3.2~) is not available (before Debian Jessie or Ubuntu Wily)
@@ -82,11 +82,11 @@ GCCVERSION=$(gcc -dumpfullversion -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g
# x86 32 bit.
if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]]
then
- sed '/Package: mariadb-plugin-rocksdb/,+10d' -i debian/control
+ sed '/Package: mariadb-plugin-rocksdb/,/^$/d' -i debian/control
fi
if [[ $GCCVERSION -lt 40800 ]]
then
- sed '/Package: mariadb-plugin-aws-key-management-10.2/,+12d' -i debian/control
+ sed '/Package: mariadb-plugin-aws-key-management-10.2/,/^$/d' -i debian/control
fi
# Don't build cassandra package if thrift is not installed